luci-base: use default install paths for host utils
authorMatthias Schiffer <mschiffer@universe-factory.net>
Mon, 3 Oct 2016 11:06:54 +0000 (13:06 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 3 Oct 2016 16:07:43 +0000 (18:07 +0200)
Also, don't make any assumptions about the staging dir lua and LuaSrcDiet
were installed to.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
luci.mk
modules/luci-base/Makefile

diff --git a/luci.mk b/luci.mk
index eb034d208106e2dd72089583f4e14447dcd3db1a..84d151230c7d8158eba88cd35af6a2581c85ca0f 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -150,8 +150,7 @@ LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
 
 define SrcDiet
        $(FIND) $(1) -type f -name '*.lua' | while read src; do \
-               if $(STAGING_DIR)/host/bin/lua $(STAGING_DIR)/host/bin/LuaSrcDiet \
-                       --noopt-binequiv -o "$$$$src.o" "$$$$src"; \
+               if LuaSrcDiet --noopt-binequiv -o "$$$$src.o" "$$$$src"; \
                then mv "$$$$src.o" "$$$$src"; fi; \
        done
 endef
index f0763cb1df51ff0f23eb821f4ab95aad5aec33d7..972a451c696f6a15a4c2429edf2fac2b61778b6b 100644 (file)
@@ -37,10 +37,9 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR)/host/bin
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
-       $(INSTALL_BIN) src/po2lmo $(STAGING_DIR_HOST)/bin/po2lmo
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(STAGING_DIR)/host/bin/LuaSrcDiet
+       $(INSTALL_DIR) $(1)/bin
+       $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
 endef
 
 $(eval $(call HostBuild))