lua-bencode: download .tar.gz instead of using hg
authorHannu Nyman <hannu.nyman@iki.fi>
Tue, 18 Apr 2017 20:33:47 +0000 (23:33 +0300)
committerHannu Nyman <hannu.nyman@iki.fi>
Tue, 18 Apr 2017 20:58:14 +0000 (23:58 +0300)
Avoid using 'hg' (Mercurial) to download sources.

'hg' is not an official prerequisite and it is not installed
in all buildslaves in Openwrt and LEDE buildbots, which
leads to frequent build failures.

Download the .tar.gz source archive instead.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
(cherry picked from commit 74e53c48425609b4f0adb0b284b71a85e4e40b88)

lang/lua-bencode/Makefile

index 0b320560875f8ffa995c60a715562546393dede8..a7b898bf52fcf166c62a3196deb119983708d3ef 100644 (file)
@@ -11,11 +11,10 @@ PKG_NAME:=lua-bencode
 PKG_VERSION:=2.1.0
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=https://bitbucket.org/wilhelmy/lua-bencode
-PKG_SOURCE_PROTO:=hg
-PKG_SOURCE_VERSION:=500243383cb6acbddd3cf12aee6e4667aab53324
+PKG_SOURCE_URL:=https://bitbucket.org/wilhelmy/lua-bencode/downloads/
+PKG_HASH:=4624f33ff026bc62990a323ee4953e42d68430c38a1a4726c9cfd77c085b1422
 PKG_LICENSE:=MIT
 
 include $(INCLUDE_DIR)/package.mk