ar71xx: backport tl-wr740n support from r24811 (#9843)
authorFelix Fietkau <nbd@openwrt.org>
Sat, 30 Jul 2011 21:57:28 +0000 (21:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 30 Jul 2011 21:57:28 +0000 (21:57 +0000)
SVN-Revision: 27841

target/linux/ar71xx/image/Makefile
target/linux/ar71xx/profiles/tp-link.mk
tools/firmware-utils/src/mktplinkfw.c

index b436003ef390d9757334aac4b3a4f951668f717f..f39be3cc68602aae3cfd870eb13b6bacabb7c828 100644 (file)
@@ -497,6 +497,10 @@ define Image/Build/Profile/TLWR741NDV1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr741nd-v1,board=TL-WR741ND,TL-WR741NDv1)
 endef
 
+define Image/Build/Profile/TLWR740NV1
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr740n-v1,board=TL-WR741ND,TL-WR740Nv1)
+endef
+
 define Image/Build/Profile/TLWR841NV15
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,board=TL-WR841N-v1.5,TL-WR841Nv1.5)
 endef
@@ -563,6 +567,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
+       $(call Image/Build/Profile/TLWR740NV1,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))
index 7efb1a3766fe643e237ef1a8ee3a73d3fa9b0172..ba08ee410b31fca1130f164330c2cb7253599cc7 100644 (file)
@@ -16,6 +16,18 @@ endef
 
 $(eval $(call Profile,TLWR741NDV1))
 
+
+define Profile/TLWR740NV1
+    NAME:=TP-LINK TL-WR740N v1
+    PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR740NV1/Description
+    Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
        PACKAGES:=kmod-ath9k wpad-mini
index cfb03f881a7f7269897e8307c4aafe466096c205..4db4bc0a9c6254a7268530ea8d6e79bd67f7eb5b 100644 (file)
@@ -34,6 +34,7 @@
 
 #define HEADER_VERSION_V1      0x01000000
 #define HWID_TL_WR741ND_V1     0x07410001
+#define HWID_TL_WR740N_V1      0x07400001
 #define HWID_TL_WR841N_V1_5    0x08410002
 #define HWID_TL_WR841ND_V3     0x08410003
 #define HWID_TL_WR841ND_V5     0x08410005
@@ -116,6 +117,14 @@ static struct board_info boards[] = {
                .kernel_la      = 0x80060000,
                .kernel_ep      = 0x80060000,
                .rootfs_ofs     = 0x140000,
+       }, {
+               .id             = "TL-WR740Nv1",
+               .hw_id          = HWID_TL_WR740N_V1,
+               .hw_rev         = 1,
+               .fw_max_len     = 0x3c0000,
+               .kernel_la      = 0x80060000,
+               .kernel_ep      = 0x80060000,
+               .rootfs_ofs     = 0x140000,
        }, {
                .id             = "TL-WR841Nv1.5",
                .hw_id          = HWID_TL_WR841N_V1_5,