ibrdtnd: Add patch to exclude build of documentation using pdflatex 285/head
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Sat, 6 Sep 2014 08:32:11 +0000 (10:32 +0200)
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Sat, 6 Sep 2014 08:40:45 +0000 (10:40 +0200)
By default the package detects the presence of pdflatex and builds documentation automatically.
During the OpenWrt build this behavior is not acceptable. The added patch introduces a configure
option to explicitly enable the build of the documentation on request.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
net/ibrdtnd/patches/110-add_configure_options_docs.patch [new file with mode: 0644]

diff --git a/net/ibrdtnd/patches/110-add_configure_options_docs.patch b/net/ibrdtnd/patches/110-add_configure_options_docs.patch
new file mode 100644 (file)
index 0000000..4efdbe2
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -138,11 +138,17 @@ AS_IF([test "x$enable_android" = "xyes"], [
+       # Checks for library functions.
+       AC_CHECK_FUNCS([gethostname socket])
+-      # Check for presence of pdfLaTeX
+-      AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
+-      if test -z "$PDFLATEX"; then
+-      AC_MSG_WARN([Unable to create PDF version of the documentation.])
+-      fi
++      AC_ARG_ENABLE([docs],
++              AS_HELP_STRING([--enable-docs], [Build documentation using PDFLaTeX]),
++      [
++              # Check for presence of pdfLaTeX
++              AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
++              if test -z "$PDFLATEX"; then
++                      AC_MSG_WARN([Unable to create PDF version of the documentation.])
++              fi
++      ], [
++              PDFLATEX="no"
++      ])
+       AC_ARG_ENABLE([libdaemon],
+               AS_HELP_STRING([--disable-libdaemon], [Build without libdaemon support]),
+--