portaudio: Pass down TARGET_CPPFLAGS only build what is necessary
authorFlorian Fainelli <f.fainelli@gmail.com>
Fri, 7 Jul 2017 22:56:37 +0000 (15:56 -0700)
committerFlorian Fainelli <f.fainelli@gmail.com>
Fri, 7 Jul 2017 22:56:37 +0000 (15:56 -0700)
We were not correctly passing down TARGET_CPPFLAGS which made external
toolchains not automatically searching for headers in $(STAGING_DIR) to
fail the build. We are also just packaging the library and headers, so
we do not need to build the tests and selftests.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
sound/portaudio/Makefile

index ffa5cfb05b91753e66e813aa14761e4d0f02b18a..c8acc1c32d3723224c33110ac209a05b060c1f43 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=portaudio
 PKG_VERSION:=19_20140130
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=pa_stable_v$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.portaudio.com/archives/
@@ -46,6 +46,12 @@ CONFIGURE_ARGS+= \
        --without-jack \
        --with-oss \
 
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+
+define Build/Compile
+       $(call Build/Compile/Default,lib/libportaudio.la)
+endef
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) \