bogofilter: remove host includes 1024/head
authorDirk Neukirchen <dirkneukirchen@web.de>
Thu, 29 Jan 2015 17:27:13 +0000 (18:27 +0100)
committerDirk Neukirchen <dirkneukirchen@web.de>
Wed, 11 Mar 2015 16:58:27 +0000 (17:58 +0100)
- host GSL libs are sometimes found leading to errors
reported by buildbot, replicated locally (Arch Linux)

Error:
configure: GSL_LIBS=-L/usr/lib -lgsl -lgslcblas -lm
leading to
/usr/include/features.h:398:23: fatal error: gnu/stubs.h: No such file or directory

- explicit libdb location to prevent host includes

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
mail/bogofilter/Makefile

index de3646b01137dbeed803f36d59ad57b083c95312..d31dfa8c1c742e4f4b233c97493ca8d5350ed4ff 100644 (file)
@@ -35,7 +35,10 @@ define Package/bogofilter/description
        Bogofilter is a fast Bayesian spam filter
 endef
 
-CONFIGURE_ARGS += --disable-unicode
+CONFIGURE_ARGS += \
+       --disable-unicode \
+       --with-libdb-prefix=$(STAGING_DIR) \
+       --with-included-gsl
 
 define Package/bogofilter/install
        $(INSTALL_DIR)  $(1)/etc/ \