seeks: fix compile on platforms with VFP
authorFlorian Fainelli <florian@openwrt.org>
Thu, 8 May 2014 00:57:42 +0000 (00:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 8 May 2014 00:57:42 +0000 (00:57 +0000)
This solution might be a little bit dirty - is adding those -mfloat-abi
switches to CXXFLAGS in rules.mk cleaner ?
but they are overwritten in this case so dunno :/

reported by buildbot on sunxi

configure fails to detect C++ compiler:
a.out uses VFP register arguments, /tmp/ccHPrqts.o does not
fixed by first change

other errors when linking:
ld: error: .libs/libseeksutils.so.0.0.0 uses VFP register arguments, .libs/miscutil.o does not
ld: error: .libs/libseeksutils.so.0.0.0 uses VFP register arguments, .libs/mem_utils.o does not
ld: error: .libs/libseeksutils.so.0.0.0 uses VFP register arguments, .libs/mutexes.o does not
fixed by second change

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 40724

net/seeks/Makefile

index 7974e568ce04b6ed85604996d43c2dcd7e533afa..49fd8e67d9a139d64ba4288b1977a4aa45173e7d 100644 (file)
@@ -50,7 +50,7 @@ endef
 
 
 CONFIGURE_VARS:= \
-        CXXFLAGS="-I$(STAGING_DIR)/usr/include $(ICONV_CFLAGS)" \
+        CXXFLAGS="-I$(STAGING_DIR)/usr/include $(ICONV_CFLAGS) $(TARGET_CFLAGS)" \
         LDFLAGS="-L$(STAGING_DIR)/usr/lib      $(ICONV_LDFLAGS)" \
 
 CONFIGURE_ARGS += \
@@ -69,7 +69,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CXXFLAGS="-I$(STAGING_DIR)/usr/include $(ICONV_CFLAGS)"
+               CXXFLAGS="-I$(STAGING_DIR)/usr/include $(ICONV_CFLAGS) $(TARGET_CFLAGS)"
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install