python: remove `011-do-not-prefer-ncursesw.patch`
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 11 Jan 2017 13:15:46 +0000 (15:15 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 11 Jan 2017 13:16:27 +0000 (15:16 +0200)
LEDE now provides libncursesw by default [even for libncurses].
No need to keep this patch around.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/patches/011-do-not-prefer-ncursesw.patch [deleted file]

diff --git a/lang/python/patches/011-do-not-prefer-ncursesw.patch b/lang/python/patches/011-do-not-prefer-ncursesw.patch
deleted file mode 100644 (file)
index c5f323c..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 7868b7b..86b0119 100644
---- a/setup.py
-+++ b/setup.py
-@@ -725,8 +725,8 @@ class PyBuildExt(build_ext):
-         # use the same library for the readline and curses modules.
-         if 'curses' in readline_termcap_library:
-             curses_library = readline_termcap_library
--        elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
--            curses_library = 'ncursesw'
-+        #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
-+        #    curses_library = 'ncursesw'
-         elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
-             curses_library = 'ncurses'
-         elif self.compiler.find_library_file(lib_dirs, 'curses'):