numpy: Fix pyproject.toml-based build
authorJeffery To <jeffery.to@gmail.com>
Wed, 10 May 2023 16:26:17 +0000 (00:26 +0800)
committerJeffery To <jeffery.to@gmail.com>
Wed, 10 May 2023 18:46:57 +0000 (02:46 +0800)
The versions of setuptools and wheel pinned in pyproject.toml are older
than the versions available in the packages repo. This unpins the
versions so that the build can proceed.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/numpy/Makefile
lang/python/numpy/patches/001-unpin-build-dependencies.patch [new file with mode: 0644]

index 35aab8d7967244cd4b2d0a9c852d6de42bf702e6..aaf9408796b118cbb96670d2fe43286e2ddebbc8 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=numpy
 PKG_VERSION:=1.23.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PYPI_NAME:=$(PKG_NAME)
 PKG_HASH:=51bf49c0cd1d52be0a240aa66f3458afc4b95d8993d2d04f0d91fa60c10af6cd
diff --git a/lang/python/numpy/patches/001-unpin-build-dependencies.patch b/lang/python/numpy/patches/001-unpin-build-dependencies.patch
new file mode 100644 (file)
index 0000000..c167f07
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -2,8 +2,8 @@
+ # Minimum requirements for the build system to execute.
+ requires = [
+     "packaging==20.5; platform_machine=='arm64'",  # macos M1
+-    "setuptools==59.2.0",
+-    "wheel==0.37.0",
++    "setuptools>=59.2.0",
++    "wheel>=0.37.0",
+     "Cython>=0.29.30,<3.0",
+ ]