utils/tar: Default to acl and xattr support if it's core default 2928/head
authorDaniel Dickinson <lede@daniel.thecshore.com>
Mon, 16 May 2016 08:27:26 +0000 (04:27 -0400)
committerDaniel Dickinson <lede@daniel.thecshore.com>
Sun, 19 Jun 2016 21:34:43 +0000 (17:34 -0400)
If we've enable POSIX ACL's and XATTR support as the default, then
make tar build with such support by default as well.

Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com>
utils/tar/Makefile

index d317329dce5233010726dd0aa28c029e00dca139..96a64215be438b83db487b4af954eef7d555515b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tar
 PKG_VERSION:=1.29
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -39,10 +39,12 @@ define Package/tar/config
        if PACKAGE_tar
                config PACKAGE_TAR_POSIX_ACL
                        bool "tar: Enable POSIX ACL support"
+                       default y if USE_FS_ACL_ATTR
                        default n
 
                config PACKAGE_TAR_XATTR
                        bool "tar: Enable extended attribute (xattr) support"
+                       default y if USE_FS_ACL_ATTR
                        default n
 
                config PACKAGE_TAR_GZIP