luci-app-advanced-reboot: add missing btn class to buttons 4781/head
authorStan Grishin <stangri@melmac.net>
Mon, 8 Feb 2021 17:37:13 +0000 (17:37 +0000)
committerStan Grishin <stangri@melmac.net>
Mon, 8 Feb 2021 17:37:13 +0000 (17:37 +0000)
Signed-off-by: Stan Grishin <stangri@melmac.net>
applications/luci-app-advanced-reboot/Makefile
applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json [new file with mode: 0644]

index 46ebedae9d04b3dff33dce64eea86d865721ffef..a4192271cd9677ed2e2a45d9d0182954eeb0b12a 100644 (file)
@@ -7,6 +7,7 @@ PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
 
 LUCI_TITLE:=Advanced Linksys Reboot Web UI
+LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
 LUCI_DESCRIPTION:=Provides Web UI (found under System/Advanced Reboot) to reboot supported Linksys and ZyXEL routers to\
        an alternative partition. Also provides Web UI to shut down (power off) your device.    Supported dual-partition\
        routers are listed at https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
index 794ac8565e5e8d701d274702847f3c6ab1a2b395..c9cc20bec069535dc52b4e4e371a1d4b3ce82c8d 100644 (file)
@@ -51,7 +51,7 @@ return view.extend({
                                        'click': ui.hideModal
                                }, _('Cancel')), ' ',
                                E('button', {
-                                       'class': 'cbi-button cbi-button-positive important',
+                                       'class': 'btn cbi-button cbi-button-positive important',
                                        'click': L.bind(this.callPowerOff, this)
                                }, _('Proceed'))
                        ])
@@ -134,7 +134,7 @@ return view.extend({
                                                'click': ui.hideModal
                                        }, _('Cancel')), ' ',
                                        E('button', {
-                                               'class': 'cbi-button cbi-button-positive important',
+                                               'class': 'btn cbi-button cbi-button-positive important',
                                                'click': L.bind(this.handleTogglePartition, this)
                                        }, _('Proceed'))
                                ])
@@ -161,7 +161,7 @@ return view.extend({
                                _(partition.state),
                                partition.os.replace("Unknown", _("Unknown")).replace("Compressed", _("Compressed")),
                                E('button', {
-                                       'class': 'cbi-button cbi-button-apply important',
+                                       'class': 'btn cbi-button cbi-button-apply important',
                                        'click': ui.createHandlerFn(this, func)
                                }, text)
                        ])
@@ -220,7 +220,7 @@ return view.extend({
                body.appendChild(E('hr'));
                body.appendChild(
                        poweroff_supported ? E('button', {
-                               'class': 'cbi-button cbi-button-apply important',
+                               'class': 'btn cbi-button cbi-button-apply important',
                                'click': ui.createHandlerFn(this, 'handlePowerOff')
                        }, _('Perform power off...'))
 
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices.disabled/netgear-wac510.json
new file mode 100644 (file)
index 0000000..b9067c4
--- /dev/null
@@ -0,0 +1,14 @@
+{
+       "vendorName": "Netgear",
+       "deviceName": "WAC510",
+       "boardNames": [ "netgear,wac510" ],
+       "partition1MTD": "mtd9",
+       "partition2MTD": "mtd10",
+       "labelOffset": null,
+       "bootEnv1": "primary",
+       "bootEnv1Partition1Value": 0,
+       "bootEnv1Partition2Value": 3800000,
+       "bootEnv2": "secondary",
+       "bootEnv2Partition1Value": 3800000,
+       "bootEnv2Partition2Value": 0
+}