Merge pull request #1875 from psidhu/master
authorSteven Barth <steven@midlink.org>
Mon, 26 Oct 2015 08:40:23 +0000 (09:40 +0100)
committerSteven Barth <steven@midlink.org>
Mon, 26 Oct 2015 08:40:23 +0000 (09:40 +0100)
gpsd: initial add to packages

35 files changed:
lang/node-cylon/patches/0001-serialport.patch [new file with mode: 0644]
lang/node/Makefile
lang/php5/Makefile
lang/python/Makefile
libs/gnutls/Makefile
libs/libcoap/Makefile
libs/libgee/Makefile [new file with mode: 0644]
libs/libgee/patches/libgee-0.18.0-no-introspection.patch [new file with mode: 0644]
libs/libsodium/Makefile
libs/libuecc/Makefile
libs/libupm/patches/002-at42qt1070-id.patch [new file with mode: 0644]
libs/libupm/patches/003-lsm303-args.patch [new file with mode: 0644]
multimedia/lcdgrilo/Makefile [new file with mode: 0644]
multimedia/lcdgrilo/files/lcdgrilo.init [new file with mode: 0644]
net/chrony/Makefile
net/chrony/files/chrony.conf
net/chrony/files/chrony.hotplug
net/chrony/files/chrony.keys [deleted file]
net/freeradius2/files/radiusd.init
net/keepalived/Makefile
net/mwan3-luci/Makefile
net/mwan3-luci/files/usr/lib/lua/luci/controller/mwan3.lua
net/mwan3-luci/files/usr/lib/lua/luci/view/mwan/openwrt_overview_status.htm
net/mwan3-luci/files/usr/lib/lua/luci/view/mwan/overview_interface.htm
net/mwan3/Makefile
net/mwan3/files/etc/hotplug.d/iface/15-mwan3
net/mwan3/files/usr/sbin/mwan3
net/wifidog/Makefile
net/wifidog/patches/100-musl-compat.patch [deleted file]
sound/mpg123/Makefile
sound/shairport-sync/Makefile
sound/shairport-sync/files/shairport-sync.config
sound/shairport-sync/files/shairport-sync.init
utils/swig/Makefile
utils/unrar/Makefile

diff --git a/lang/node-cylon/patches/0001-serialport.patch b/lang/node-cylon/patches/0001-serialport.patch
new file mode 100644 (file)
index 0000000..08d579c
--- /dev/null
@@ -0,0 +1,12 @@
+Index: node-cylon-0.22.0/package.json
+===================================================================
+--- node-cylon-0.22.0.orig/package.json        2015-10-20 20:32:48.000000000 +0200
++++ node-cylon-0.22.0/package.json     2015-10-21 10:42:20.616109122 +0200
+@@ -38,7 +38,6 @@
+   },
+   "dependencies": {
+-    "firmata":    ">= 0.3.2",
+     "cylon":      "1.1.0",
+     "cylon-gpio": "0.26.0",
+     "cylon-i2c":  "0.22.0"
index 98a76b88cdbb40d15ac02834bc66298da1da1810..74eb44e432bf58c1b49194470e5fafdf4336a893 100644 (file)
@@ -14,6 +14,7 @@ PKG_RELEASE:=1
 PKG_SOURCE:=node-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://nodejs.org/dist/${PKG_VERSION}
 
+PKG_BUILD_DEPENDS:=python/host
 PKG_INSTALL:=1
 
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
index 6c302b9ef85cdd9e339f513e14fb0d52679a5a21..cd6989a49f32d5cb3aa9ce63d9b92d55670015ab 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
-PKG_VERSION:=5.6.13
+PKG_VERSION:=5.6.14
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>, Michael Heimpold <mhei@heimpold.de>
@@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=LICENSE
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
-PKG_MD5SUM:=64d9a82068e3b0bbb16c261261391172
+PKG_MD5SUM:=2e1332123a7e19d15ed2af2d1d6bd6fd
 
 PKG_FIXUP:=libtool autoreconf
 PKG_BUILD_PARALLEL:=1
index 8cd41af02e905910a2bd9f33e8b848d5233cfd01..698f4bee6d5736aa22f417db7c4879f26e1f2b3e 100644 (file)
@@ -28,7 +28,8 @@ HOST_BUILD_PARALLEL:=1
 PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
 
-PKG_BUILD_DEPENDS:=libbz2/host python/host
+PKG_BUILD_DEPENDS:=python/host
+HOST_BUILD_DEPENDS:=bzip2/host
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
index b6cd2de410d11eeb3ec94adcabfe9cfcc21d6478..8dbf7217c0c5ed333ad901b9c83b0a62a5d23e78 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
-PKG_VERSION:=3.4.5
+PKG_VERSION:=3.4.6
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4
-PKG_MD5SUM:=f5dae0e0ecda28aab12386e6c0705d4c
+PKG_MD5SUM:=4f2c4b4483da65de7edfeb050911fafb
 #PKG_FIXUP:=autoreconf gettext-version
 PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
 PKG_LICENSE:=LGPLv2.1+
index 41d553599a63a915423280a476048e1d6e7f3a7f..8e6ef5d250324b5d42ddfcb44f2f23be00e31622 100644 (file)
@@ -42,6 +42,10 @@ CONFIGURE_ARGS += \
        --disable-examples \
        --disable-documentation
 
+ifeq ($(CONFIG_BIG_ENDIAN),y)
+TARGET_CFLAGS += -DWORDS_BIGENDIAN
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
diff --git a/libs/libgee/Makefile b/libs/libgee/Makefile
new file mode 100644 (file)
index 0000000..87705e3
--- /dev/null
@@ -0,0 +1,69 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libgee
+PKG_VERSION:=0.18.0
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=LGPL-2.1 
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://download.gnome.org/sources/libgee/0.18/
+PKG_MD5SUM:=29ea6125e653d7e60b49a9a9544abc96
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/libgee
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+glib2
+  TITLE:=libgee
+  URL:=https://wiki.gnome.org/Libgee
+endef
+
+define Package/libgee/decription
+  Libgee is an utility library providing GObject-based interfaces and classes
+endef
+
+CONFIGURE_ARGS += \
+       --disable-doc
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/gee-0.8/ \
+               $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libgee/install
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libgee))
diff --git a/libs/libgee/patches/libgee-0.18.0-no-introspection.patch b/libs/libgee/patches/libgee-0.18.0-no-introspection.patch
new file mode 100644 (file)
index 0000000..caa6e16
--- /dev/null
@@ -0,0 +1,101 @@
+diff -u --recursive libgee-0.18.0-vanilla/configure.ac libgee-0.18.0/configure.ac
+--- libgee-0.18.0-vanilla/configure.ac 2015-03-23 23:24:39.000000000 -0400
++++ libgee-0.18.0/configure.ac 2015-10-18 07:25:39.474698663 -0400
+@@ -64,10 +64,6 @@
+               enable_consistency_check=$enableval, enable_consistency_check=no)
+ AS_IF([test "x$enable_consistency_check" != xno], [VALA_ADD_VALAFLAGS(-D CONSISTENCY_CHECKS)])
+-GOBJECT_INTROSPECTION_CHECK([0.9.0])
+-
+-VALA_CHECK([0.25.1])
+-
+ AC_OUTPUT([Makefile
+            gee-0.8.pc
+            benchmark/Makefile
+diff -u --recursive libgee-0.18.0-vanilla/gee/Makefile.am libgee-0.18.0/gee/Makefile.am
+--- libgee-0.18.0-vanilla/gee/Makefile.am      2015-03-16 11:23:57.000000000 -0400
++++ libgee-0.18.0/gee/Makefile.am      2015-10-18 10:41:49.759314756 -0400
+@@ -146,29 +146,6 @@
+       gee-0.8.vapi \
+       $(NULL)
+-if HAVE_INTROSPECTION
+-girdir = @INTROSPECTION_GIRDIR@
+-
+-dist_gir_DATA = \
+-      Gee-0.8.gir \
+-      $(NULL)
+-
+-typelibdir = @INTROSPECTION_TYPELIBDIR@
+-typelib_DATA = \
+-      Gee-0.8.typelib \
+-      $(NULL)
+-
+-# Extract dlname from libfolks.la; see bug #658002.
+-# This is what g-ir-scanner does.
+-libgee_dlname = \
+-      `$(SED) -nE "s/^dlname='([A-Za-z0-9.+-]+)'/\1/p" libgee-0.8.la`
+-INTROSPECTION_COMPILER_ARGS= \
+-      -l $(libgee_dlname)
+-Gee-0.8.gir: libgee_0_8_la_vala.stamp
+-Gee-0.8.typelib: Gee-0.8.gir libgee-0.8.la
+-      @INTROSPECTION_COMPILER@ $(INTROSPECTION_COMPILER_ARGS) -o $@ $^
+-endif
+-
+ MOSTLYCLEANFILES = \
+       $(libgee_0_8_la_VALASOURCES:.vala=.c) \
+       libgee_0_8_la_vala.stamp \
+diff -u --recursive libgee-0.18.0-vanilla/gee/Makefile.in libgee-0.18.0/gee/Makefile.in
+--- libgee-0.18.0-vanilla/gee/Makefile.in      2015-03-23 23:25:03.000000000 -0400
++++ libgee-0.18.0/gee/Makefile.in      2015-10-18 11:02:34.888709559 -0400
+@@ -285,14 +285,6 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+-INTROSPECTION_CFLAGS = @INTROSPECTION_CFLAGS@
+-INTROSPECTION_COMPILER = @INTROSPECTION_COMPILER@
+-INTROSPECTION_GENERATE = @INTROSPECTION_GENERATE@
+-INTROSPECTION_GIRDIR = @INTROSPECTION_GIRDIR@
+-INTROSPECTION_LIBS = @INTROSPECTION_LIBS@
+-INTROSPECTION_MAKEFILE = @INTROSPECTION_MAKEFILE@
+-INTROSPECTION_SCANNER = @INTROSPECTION_SCANNER@
+-INTROSPECTION_TYPELIBDIR = @INTROSPECTION_TYPELIBDIR@
+ LCOV = @LCOV@
+ LD = @LD@
+ LDFLAGS = @LDFLAGS@
+@@ -531,25 +523,6 @@
+       gee-0.8.vapi \
+       $(NULL)
+-@HAVE_INTROSPECTION_TRUE@girdir = @INTROSPECTION_GIRDIR@
+-@HAVE_INTROSPECTION_TRUE@dist_gir_DATA = \
+-@HAVE_INTROSPECTION_TRUE@     Gee-0.8.gir \
+-@HAVE_INTROSPECTION_TRUE@     $(NULL)
+-
+-@HAVE_INTROSPECTION_TRUE@typelibdir = @INTROSPECTION_TYPELIBDIR@
+-@HAVE_INTROSPECTION_TRUE@typelib_DATA = \
+-@HAVE_INTROSPECTION_TRUE@     Gee-0.8.typelib \
+-@HAVE_INTROSPECTION_TRUE@     $(NULL)
+-
+-
+-# Extract dlname from libfolks.la; see bug #658002.
+-# This is what g-ir-scanner does.
+-@HAVE_INTROSPECTION_TRUE@libgee_dlname = \
+-@HAVE_INTROSPECTION_TRUE@     `$(SED) -nE "s/^dlname='([A-Za-z0-9.+-]+)'/\1/p" libgee-0.8.la`
+-
+-@HAVE_INTROSPECTION_TRUE@INTROSPECTION_COMPILER_ARGS = \
+-@HAVE_INTROSPECTION_TRUE@     -l $(libgee_dlname)
+-
+ MOSTLYCLEANFILES = \
+       $(libgee_0_8_la_VALASOURCES:.vala=.c) \
+       libgee_0_8_la_vala.stamp \
+@@ -1607,9 +1580,6 @@
+ $(libgee_0_8_la_VALASOURCES:.vala=.c): libgee_0_8_la_vala.stamp
+ gee-0.8.vapi gee-internals-0.8.vapi gee.h gee-internals.h: libgee_0_8_la_vala.stamp
+-@HAVE_INTROSPECTION_TRUE@Gee-0.8.gir: libgee_0_8_la_vala.stamp
+-@HAVE_INTROSPECTION_TRUE@Gee-0.8.typelib: Gee-0.8.gir libgee-0.8.la
+-@HAVE_INTROSPECTION_TRUE@     @INTROSPECTION_COMPILER@ $(INTROSPECTION_COMPILER_ARGS) -o $@ $^
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
index 44810947286a4fb45e6f59be6b46d51f2256a63d..8b43af4196384292962953dee670cc31730268bd 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsodium
-PKG_VERSION:=1.0.3
+PKG_VERSION:=1.0.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://download.libsodium.org/libsodium/releases
-PKG_MD5SUM:=b3bcc98e34d3250f55ae196822307fab
+PKG_MD5SUM:=f3d077d856c3742515fa8fe12ddb2c0f
 
 PKG_FIXUP:=libtool autoreconf
 PKG_USE_MIPS16:=0
index 63b6ebe217fc2ff105a1a223807c610c31158eb8..fb269339ce073d1b51840b6efefe00838445ce61 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libuecc
-PKG_VERSION:=5
+PKG_VERSION:=6
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Matthias Schiffer <mschiffer@universe-factory.net>
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=https://projects.universe-factory.net/attachments/download/80
-PKG_MD5SUM:=cd03c947931c2f4b0eea0bf45654bd34
+PKG_SOURCE_URL:=https://projects.universe-factory.net/attachments/download/83
+PKG_MD5SUM:=cba68339ff46482ec4090303de18fff4
 
 PKG_LICENSE:=BSD-2-Clause
 PKG_LICENSE_FILES:=COPYRIGHT
diff --git a/libs/libupm/patches/002-at42qt1070-id.patch b/libs/libupm/patches/002-at42qt1070-id.patch
new file mode 100644 (file)
index 0000000..85544c9
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/at42qt1070/at42qt1070.cxx
++++ b/src/at42qt1070/at42qt1070.cxx
+@@ -53,7 +53,7 @@
+         return;
+     }
+-    if (readChipID() != 0x2E) {
++    if (readChipID() != 0x1b && readChipID() != 0x2E) {
+         throw std::runtime_error("Chip ID does not match the expected value (2Eh)");
+     }
diff --git a/libs/libupm/patches/003-lsm303-args.patch b/libs/libupm/patches/003-lsm303-args.patch
new file mode 100644 (file)
index 0000000..d2b2d0e
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/lsm303/lsm303.h
++++ b/src/lsm303/lsm303.h
+@@ -34,7 +34,7 @@
+ /* LSM303 Address definitions */
+ #define LSM303_MAG 0x1E // assuming SA0 grounded
+-#define LSM303_ACC 0x18 // assuming SA0 grounded
++#define LSM303_ACC 0x1E // assuming SA0 grounded
+ /* LSM303 Register definitions */
+ #define CTRL_REG1_A 0x20
diff --git a/multimedia/lcdgrilo/Makefile b/multimedia/lcdgrilo/Makefile
new file mode 100644 (file)
index 0000000..53888d1
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lcdgrilo
+PKG_VERSION:=0.0.7
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.flyn.org/projects/lcdgrilo
+PKG_MD5SUM:=80a946bf144da5cc32bdf9f1aa2f91e6
+PKG_BUILD_DEPENDS:=+vala
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/lcdgrilo
+  SECTION:=multimedia
+  CATEGORY:=Multimedia
+  DEPENDS:=+grilo +grilo-plugins +libgee +libgstreamer1
+  TITLE:=lcdgrilo
+  URL:=http://www.flyn.org/projects/lcdgrilo/
+endef
+
+define Package/lcdgrilo/decription
+       A simple Grilo-based audio player meant to run on a Raspberry Pi with a PiFace CAD
+endef
+
+define Package/lcdgrilo/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/bin/lcdgrilo \
+               $(1)/usr/bin/
+       $(INSTALL_BIN) ./files/lcdgrilo.init $(1)/etc/init.d/lcdgrilo
+endef
+
+$(eval $(call BuildPackage,lcdgrilo))
diff --git a/multimedia/lcdgrilo/files/lcdgrilo.init b/multimedia/lcdgrilo/files/lcdgrilo.init
new file mode 100644 (file)
index 0000000..5c4ff1b
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2009-2012 OpenWrt.org
+
+START=60
+
+start() {
+       /usr/bin/lcdgrilo &
+       echo $! > /var/run/lcdgrilo.pid
+}
+
+stop() {
+       if [ ! -f /var/run/lcdgrilo.pid ]; then
+               return
+       fi
+       /bin/kill `cat /var/run/lcdgrilo.pid`
+}
index 9b0f7e7d16f35bfe55c3703ae3d2f77a3a343aca..5ef68cfa6fcdb4f42ad1b2e2b48ad930294babf5 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chrony
-PKG_VERSION:=2.1.1
+PKG_VERSION:=2.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.tuxfamily.org/chrony/
-PKG_MD5SUM:=15e470a51ab6e09e65bc0a2fbc5299af
+PKG_MD5SUM:=17bc77d3d2ce942675f9600b60452717
 
 PKG_MAINTAINER:=Miroslav Lichvar <mlichvar0@gmail.com>
 PKG_LICENSE:=GPL-2.0
@@ -41,7 +41,6 @@ endef
 
 define Package/chrony/conffiles
 /etc/chrony/chrony.conf
-/etc/chrony/chrony.keys
 /etc/config/chrony
 endef
 
@@ -51,6 +50,7 @@ CONFIGURE_ARGS+= \
        --host-system=Linux \
        --sysconfdir=/etc/chrony \
        --prefix=/usr \
+       --chronysockdir=/var/run/chrony \
        --disable-readline \
        --disable-rtc \
        --disable-asyncdns \
@@ -71,7 +71,6 @@ define Package/chrony/install
        $(INSTALL_BIN) ./files/chronyd.init $(1)/etc/init.d/chronyd
        $(INSTALL_CONF) ./files/chrony.config $(1)/etc/config/chrony
        $(INSTALL_CONF) ./files/chrony.conf $(1)/etc/chrony/chrony.conf
-       $(INSTALL_CONF) ./files/chrony.keys $(1)/etc/chrony/chrony.keys
 endef
 
 $(eval $(call BuildPackage,chrony))
index da0aa60ac8ff3108b26fe38658c76048169e96f8..b207c945e2d168d856a04248370ce7e71d5ccd35 100644 (file)
@@ -5,8 +5,3 @@ logchange 0.5
 
 # Don't log client accesses
 noclientlog
-
-# Password config for chronyc
-keyfile /etc/chrony/chrony.keys
-commandkey 1
-generatecommandkey
index 40843363a0c3edb99efed8bf8d036f75f7faa616..5f6a14b283b2656ad7d79bde3aeb62159b62cad2 100644 (file)
@@ -2,5 +2,5 @@ COMMAND=/usr/bin/chronyc
 
 [ -x $COMMAND ] || exit 0
 
-[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && $COMMAND -a online
-[ "$ACTION" = "ifdown" -a "$INTERFACE" = "wan" ] && $COMMAND -a offline
+[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && $COMMAND online
+[ "$ACTION" = "ifdown" -a "$INTERFACE" = "wan" ] && $COMMAND offline
diff --git a/net/chrony/files/chrony.keys b/net/chrony/files/chrony.keys
deleted file mode 100644 (file)
index f5f6319..0000000
+++ /dev/null
@@ -1 +0,0 @@
-# Keys for NTP authentication and chronyc commands
index 27f75c6ef0bfaba3933fd961d0f7776fffa31a51..e529a889185c3c08c496dd18181df55426469ae4 100644 (file)
@@ -1,22 +1,27 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+
+USE_PROCD=1
+
 START=50
 
+NAME=radiusd
+PROG=/usr/sbin/radiusd
 DEFAULT=/etc/default/radiusd
-LOG_D=/var/log
-RUN_D=/var/run
-PID_F=$RUN_D/radiusd.pid
-RADACCT_D=/var/db/radacct
-IPADDR=$(ifconfig br-lan | sed -n 's/.*dr:\(.*\)Bc.*/\1/p')
 
-start() {
+start_service()
+{
        [ -f $DEFAULT ] && . $DEFAULT
-       mkdir -p $LOG_D
-       mkdir -p $RUN_D
-       mkdir -p $RADACCT_D
-       radiusd -i $IPADDR -p 1812,1813 $OPTIONS
-}
+       mkdir -p /var/log
+       mkdir -p /var/run
+       mkdir -p /var/db/radacct
 
-stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       procd_open_instance
+       procd_set_param command $PROG
+       [ -n "$IPADDR" ] && procd_append_param command -i $IPADDR
+       [ -n "$OPTIONS" ] && procd_append_param command $OPTIONS
+       procd_set_param respawn
+       procd_close_instance
 }
index b68c726bc3990a5379953b27d12fd43040d5731d..6d7d93c741ea89489f736643b17443b9980d0f2e 100644 (file)
@@ -29,7 +29,7 @@ define Package/keepalived
   CATEGORY:=Network
   TITLE:=Failover and monitoring daemon for LVS clusters
   URL:=http://www.keepalived.org/
-  DEPENDS:=+libnl +libopenssl
+  DEPENDS:=+libnl-genl +libopenssl
 endef
 
 define Package/keepalived/description
index d74b15263ddeb43581c1d4eb0b40304e0072c904..b4b49ce00a65518af351f138cfeffaa0fd4d565c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luci-app-mwan3
 PKG_VERSION:=1.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_MAINTAINER:=Aedan Renner <chipdankly@gmail.com>
 PKG_LICENSE:=GPLv2
 
index 7fe4442c9a9b4bdfddc0a21b94557749e4c65819..bd343608ea5c970d79b26d2d8dbfca00165a19d0 100644 (file)
@@ -3,6 +3,8 @@ module("luci.controller.mwan3", package.seeall)
 sys = require "luci.sys"
 ut = require "luci.util"
 
+ip = "/usr/bin/ip -4 "
+
 function index()
        if not nixio.fs.access("/etc/config/mwan3") then
                return
@@ -61,7 +63,7 @@ end
 
 function getInterfaceStatus(ruleNumber, interfaceName)
        if ut.trim(sys.exec("uci -p /var/state get mwan3." .. interfaceName .. ".enabled")) == "1" then
-               if ut.trim(sys.exec("ip route list table " .. ruleNumber)) ~= "" then
+               if ut.trim(sys.exec(ip .. "route list table " .. ruleNumber)) ~= "" then
                        if ut.trim(sys.exec("uci -p /var/state get mwan3." .. interfaceName .. ".track_ip")) ~= "" then
                                return "online"
                        else
@@ -183,8 +185,8 @@ function diagnosticsData(interface, tool, task)
                                end
                        elseif tool == "rulechk" then
                                getInterfaceNumber()
-                               local rule1 = sys.exec("ip rule | grep $(echo $((" .. interfaceNumber .. " + 1000)))")
-                               local rule2 = sys.exec("ip rule | grep $(echo $((" .. interfaceNumber .. " + 2000)))")
+                               local rule1 = sys.exec(ip .. "rule | grep $(echo $((" .. interfaceNumber .. " + 1000)))")
+                               local rule2 = sys.exec(ip .. "rule | grep $(echo $((" .. interfaceNumber .. " + 2000)))")
                                if rule1 ~= "" and rule2 ~= "" then
                                        results = "All required interface IP rules found:\n\n" .. rule1 .. rule2
                                elseif rule1 ~= "" or rule2 ~= "" then
@@ -194,7 +196,7 @@ function diagnosticsData(interface, tool, task)
                                end
                        elseif tool == "routechk" then
                                getInterfaceNumber()
-                               local routeTable = sys.exec("ip route list table " .. interfaceNumber)
+                               local routeTable = sys.exec(ip .. "route list table " .. interfaceNumber)
                                if routeTable ~= "" then
                                        results = "Interface routing table " .. interfaceNumber .. " was found:\n\n" .. routeTable
                                else
@@ -283,17 +285,17 @@ function troubleshootingData()
        mArray.routeshow = { routeShow }
 
        -- ip rule show
-       local ipRuleShow = ut.trim(sys.exec("ip rule show"))
+       local ipRuleShow = ut.trim(sys.exec(ip .. "rule show"))
                if ipRuleShow == "" then
                        ipRuleShow = "No data found"
                end
        mArray.iprule = { ipRuleShow }
 
        -- ip route list table 1-250
-       local routeList, routeString = ut.trim(sys.exec("ip rule | sed 's/://g' | awk '$1>=2001 && $1<=2250' | awk '{print $NF}'")), ""
+       local routeList, routeString = ut.trim(sys.exec(ip .. "rule | sed 's/://g' | awk '$1>=2001 && $1<=2250' | awk '{print $NF}'")), ""
                if routeList ~= "" then
                        for line in routeList:gmatch("[^\r\n]+") do
-                               routeString = routeString .. line .. "\n" .. sys.exec("ip route list table " .. line)
+                               routeString = routeString .. line .. "\n" .. sys.exec(ip .. "route list table " .. line)
                        end
                        routeString = ut.trim(routeString)
                else
index 6dec9c8e24905715a537163ea4245e3035e48e41..9329b927355793cb31ced40cc1d80124c259987d 100644 (file)
@@ -6,7 +6,7 @@
                        if (mArray.wans)
                        {
                                var temp = '';
-                               for( var i = 0; i < mArray.wans.length; i++ )
+                               for ( var i = 0; i < mArray.wans.length; i++ )
                                {
                                        var stat = '';
                                        var cssc = '';
index 776fd4ce22437220e75cb4ea32fd3fd14515da6f..472c7ce7fcbdbb55450c2c0aa4e1b1b7ee8c5631 100644 (file)
@@ -14,7 +14,7 @@
                        if (mArray.wans)
                        {
                                var interfaceStatus = '';
-                               for( var i = 0; i < mArray.wans.length; i++ )
+                               for ( var i = 0; i < mArray.wans.length; i++ )
                                {
                                        var status = '';
                                        var css = '';
index 97511b9985df32852e99bf272eb224e837e7f327..bcf56f05ef4c6c58872c9ef9fd7e6bcd86765c33 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mwan3
 PKG_VERSION:=1.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MAINTAINER:=Jeroen Louwes <jeroen.louwes@gmail.com>
 PKG_LICENSE:=GPLv2
 
index f117e49e6bc24a5f4356d438808d328bcbcaba0f..12423c794f867ca60011dc4df8bbbcacb7133868 100644 (file)
@@ -1,5 +1,41 @@
 #!/bin/sh
 
+local IP IPS IPT LOG
+
+[ -n "$ACTION" ] || exit 0
+[ -n "$INTERFACE" ] || exit 0
+
+if [ $ACTION == "ifup" ]; then
+        [ -n "$DEVICE" ] || exit 0
+fi
+
+if [ -x /usr/sbin/ip ]; then
+        IP="/usr/sbin/ip -4"
+elif [ -x /usr/bin/ip ]; then
+        IP="/usr/bin/ip -4"
+else
+        exit 1
+fi
+
+if [ -x /usr/sbin/ipset ]; then
+        IPS="/usr/sbin/ipset"
+else
+        exit 1
+fi
+
+if [ -x /usr/sbin/iptables ]; then
+        IPT="/usr/sbin/iptables -t mangle -w"
+else
+        exit 1
+fi
+
+if [ -x /usr/bin/logger ]; then
+        LOG="/usr/bin/logger -t mwan3 -p"
+else
+        exit 1
+fi
+
+
 mwan3_get_iface_id()
 {
        let iface_count++
@@ -398,25 +434,6 @@ mwan3_ifupdown()
        config_foreach mwan3_set_user_rules_iptables rule
 }
 
-[ -n "$ACTION" ] || exit 0
-[ -n "$INTERFACE" ] || exit 0
-
-if [ $ACTION == "ifup" ]; then
-       [ -n "$DEVICE" ] || exit 0
-fi
-
-[ -x /usr/sbin/ip ] || exit 1
-[ -x /usr/sbin/ipset ] || exit 1
-[ -x /usr/sbin/iptables ] || exit 1
-[ -x /usr/bin/logger ] || exit 1
-
-local IP IPS IPT LOG
-
-IP="/usr/sbin/ip -4"
-IPS="/usr/sbin/ipset"
-IPT="/usr/sbin/iptables -t mangle -w"
-LOG="/usr/bin/logger -t mwan3 -p"
-
 case "$ACTION" in
        ifup|ifdown)
                mwan3_ifupdown
index b887fa5e6b446e99312c3c9c814f34c8bde00f7e..a5da22ac9ffcff4a36472b56f0cc53fd92db276e 100755 (executable)
@@ -1,9 +1,26 @@
 #!/bin/sh
-. /lib/functions.sh
 
-IP="/usr/sbin/ip -4"
-IPS="/usr/sbin/ipset"
-IPT="/usr/sbin/iptables -t mangle -w"
+if [ -x /usr/sbin/ip ]; then
+        IP="/usr/sbin/ip -4"
+elif [ -x /usr/bin/ip ]; then
+        IP="/usr/bin/ip -4"
+else
+        exit 1
+fi
+
+if [ -x /usr/sbin/ipset ]; then
+        IPS="/usr/sbin/ipset"
+else
+        exit 1
+fi
+
+if [ -x /usr/sbin/iptables ]; then
+        IPT="/usr/sbin/iptables -t mangle -w"
+else
+        exit 1
+fi
+
+. /lib/functions.sh
 
 help()
 {
index ddc2bb1faee598c29604a828444ba8d7cccc27c9..591f29107b294ed5c67c69f40fbad91f588b032e 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wifidog
-PKG_VERSION:=1.2.1
-PKG_RELEASE=2
+PKG_VERSION:=1.3.0
+PKG_RELEASE=1
 
 
 PKG_LICENSE:=GPL-2.0
@@ -22,7 +22,7 @@ PKG_LICENSE_FILES:=COPYING
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://github.com/wifidog/wifidog-gateway.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=1.2.1
+PKG_SOURCE_VERSION:=1.3.0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 PKG_FIXUP:=autoreconf
diff --git a/net/wifidog/patches/100-musl-compat.patch b/net/wifidog/patches/100-musl-compat.patch
deleted file mode 100644 (file)
index 599c1fe..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
---- a/libhttpd/protocol.c
-+++ b/libhttpd/protocol.c
-@@ -28,6 +28,7 @@
- #if defined(_WIN32)
- #else
-+#include <fcntl.h>
- #include <unistd.h>
- #include <sys/file.h>
- #endif
---- a/src/firewall.c
-+++ b/src/firewall.c
-@@ -35,7 +35,6 @@
- #include <pthread.h>
- #include <sys/wait.h>
- #include <sys/types.h>
--#include <sys/unistd.h>
- #include <string.h>
---- a/src/client_list.c
-+++ b/src/client_list.c
-@@ -31,9 +31,9 @@
- #include <syslog.h>
- #include <errno.h>
- #include <pthread.h>
-+#include <unistd.h>
- #include <sys/wait.h>
- #include <sys/types.h>
--#include <sys/unistd.h>
- #include <string.h>
---- a/src/util.c
-+++ b/src/util.c
-@@ -33,10 +33,10 @@
- #include <syslog.h>
- #include <errno.h>
- #include <pthread.h>
-+#include <unistd.h>
- #include <sys/wait.h>
- #include <sys/types.h>
- #include <sys/time.h>
--#include <sys/unistd.h>
- #include <netinet/in.h>
- #include <sys/ioctl.h>
- #include <arpa/inet.h>
index 2eeff44cfc71dcf09c8a8e895a7514b1a9bcd656..60697c0ff85faffbdcc02f9b009843de3e97f106 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpg123
 PKG_VERSION:=1.22.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.mpg123.de/download/
@@ -43,7 +43,7 @@ define Package/mpg123
   SECTION:=sound
   CATEGORY:=Sound
   TITLE:=fast console mpeg audio player
-  DEPENDS+=+libmpg123 +alsa-lib +libsdl +libpthread
+  DEPENDS+=+libmpg123 +alsa-lib
 endef
 
 define Build/Configure
@@ -51,6 +51,7 @@ define Build/Configure
                --enable-shared \
                --enable-static \
                --with-cpu=generic_nofpu \
+               --with-default-audio=alsa \
        )
 endef
 
@@ -86,7 +87,8 @@ endef
 define Package/mpg123/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/bin/mpg123 \
+               $(PKG_INSTALL_DIR)/usr/bin/mpg123{,-id3dump,-strip} \
+               $(PKG_INSTALL_DIR)/usr/bin/out123
                $(1)/usr/bin
 
        $(INSTALL_DIR) $(1)/usr/lib/mpg123
index 1cb6f57a81de8e4cac47b861491833a9055e6e5b..4d98052701c1801532d271ea441c264cfffe3171 100644 (file)
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=shairport-sync
-PKG_VERSION:=2.4.1
-PKG_RELEASE:=2
+PKG_VERSION:=2.6
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://github.com/mikebrady/shairport-sync.git
index 289a3785541a6bd4db7fb623d3c894b5ebd47e45..0640bde3b88827e8b17580efe8154cc0e238cb50 100644 (file)
@@ -23,6 +23,7 @@ config shairport-sync 'shairport_sync'
        option resync_threshold '' # 2205
        option log_verbosity '' # 0/1/2/3
        option ignore_volume_control '' # no/yes
+       option volume_range_db '' # 30 to 150
        # Latencies
        option latencies_default '' # 88200
        option latencies_itunes '' # 99400
index 2631401c15953aca222515a7fbe315d00e78e8fa..ac4b5898fed87250821db35b5c1dfbb42a653afe 100644 (file)
@@ -58,6 +58,7 @@ start_instance() {
                append_num "$cfg" "$conf_file" resync_threshold "resync_threshold"
                append_num "$cfg" "$conf_file" log_verbosity "log_verbosity"
                append_str "$cfg" "$conf_file" ignore_volume_control "ignore_volume_control"
+               append_num "$cfg" "$conf_file" volume_range_db "volume_range_db"
                echo -e "};\n" >> $conf_file
 
                # Latencies
index b7340ca9ff97bee4ddc4c672cde4931c97e2e625..7b9c4f09fc41b8d0e1458dc67ce22cecf3c9f03f 100644 (file)
@@ -28,6 +28,9 @@ define Package/swig
   BUILDONLY:=1
 endef
 
+HOST_CONFIGURE_ARGS+= \
+       --without-pcre
+
 define Package/swig/description
   tool that generates bindings for various languages
 endef
index 45cbc8eb06a0acffca857f9d33ac1264575df8a6..e9ca1f16aaadcaa3f8a61fc8ed54bee97616bc9b 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unrar
-PKG_VERSION:=5.3.5
+PKG_VERSION:=5.3.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=unrarsrc-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.rarlab.com/rar
-PKG_MD5SUM:=687fc04817d138b988739b0e3c8f83db
+PKG_MD5SUM:=3c58a7e9e6bdf34dee7db72f299b05e8
 PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 
 PKG_LICENSE:=UnRAR
@@ -25,21 +25,40 @@ PKG_INSTALL:=1
 include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
-define Package/unrar
-  SECTION:=utils
-  CATEGORY:=Utilities
+define Package/unrar/Default
+  TITLE:=UnRAR
   SUBMENU:=Compression
-  TITLE:=UnRAR application
   URL:=http://www.rarlab.com/
   DEPENDS:=$(CXX_DEPENDS) +libpthread
 endef
 
+define Package/unrar
+$(call Package/unrar/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE+= (application)
+endef
+
+define Package/libunrar
+$(call Package/unrar/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE+= (library)
+endef
+
 define Package/unrar/description
-   UnRAR is an application that can decompress files and archives created using
-   the RAR compression scheme
+  UnRAR is an application that can decompress files and archives created using
+  the RAR compression scheme
 endef
 
-define Build/Configure
+define Package/libunrar/description
+  UnRAR library is a shared library that provides file extraction from RAR
+  archives
+endef
+
+define Build/Compile
+       $(call Build/Compile/Default,unrar)
+       $(call Build/Compile/Default,lib)
 endef
 
 define Package/unrar/install
@@ -47,4 +66,10 @@ define Package/unrar/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/unrar $(1)/usr/bin/
 endef
 
+define Package/libunrar/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libunrar.so $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,unrar))
+$(eval $(call BuildPackage,libunrar))