netatalk: don't use bundled libevent 7599/head
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Thu, 6 Dec 2018 20:29:46 +0000 (18:29 -0200)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Thu, 6 Dec 2018 20:48:06 +0000 (18:48 -0200)
libevent2 bundled with netatalk is not compatible with openssl 1.1.x.
The binary that links to it, netatalk, is not included in the final
package, so there's no dependency to add.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
net/netatalk/Makefile

index 6cbae4dcca820821f0928e4688ab10aeaa106d96..6068020dbe241b86d467d304e5dc3754ca2de236 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netatalk
 PKG_VERSION:=3.1.11
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/netatalk
@@ -19,6 +19,8 @@ PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 PKG_FIXUP:=autoreconf
 
+PKG_BUILD_DEPENDS:=libevent2
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/netatalk
@@ -50,6 +52,7 @@ CONFIGURE_ARGS += \
        --disable-tcp-wrappers \
        --with-cnid-default-backend=dbd \
        --with-bdb="$(STAGING_DIR)/usr/" \
+       --with-libevent=no \
        --with-libgcrypt-dir="$(STAGING_DIR)/usr" \
        --with-ssl-dir="$(STAGING_DIR)/usr" \
        --with-uams-path="/usr/lib/uams" \