ola: fix compilation with GCC4
authorRosen Penev <rosenp@gmail.com>
Mon, 25 May 2020 02:56:00 +0000 (19:56 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 31 May 2020 21:01:32 +0000 (14:01 -0700)
The configure script confusingly sets CXXFLAGS to gnu++11 but does
not use that to check the important stuff. Fix that.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/ola/Makefile

index 291b06a35790679ac9947174cc6e3c7824359172..5e436bac23a048859f967a7abedef48db5ca4659 100644 (file)
@@ -65,6 +65,9 @@ HOST_CONFIGURE_ARGS += \
        --disable-doxygen-html \
        --disable-doxygen-doc
 
+HOST_CPPFLAGS += \
+       -std=gnu++11
+
 HOST_LDFLAGS += -Wl,-rpath="$(STAGING_DIR_HOSTPKG)/lib"
 TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lm)