peercast: add -fpermissive to avoid build breakage
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:09:28 +0000 (21:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:09:28 +0000 (21:09 +0000)
SVN-Revision: 32538

multimedia/peercast/Makefile

index afbcda1b7fe346e3c46b6c19b8544b30dd3bb454..fec240be81ea9d6bd33804c42e434fb856f6554f 100644 (file)
@@ -48,6 +48,8 @@ CONFIGURE_ARGS += \
 CONFIGURE_VARS += \
        LIBS="-lpthread"
 
+TARGET_CFLAGS += -fpermissive
+
 define Package/peercast/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/peercast $(1)/usr/sbin/