octeon: prepare elf kernel image and md5sum for usb copying
authorJohn Crispin <john@openwrt.org>
Mon, 6 Oct 2014 20:05:39 +0000 (20:05 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 6 Oct 2014 20:05:39 +0000 (20:05 +0000)
Signed-off-by: Roman Yeryomin <roman@advem.lv>
SVN-Revision: 42809

target/linux/octeon/image/Makefile

index 25a81496b2dac7051429127b83b6ba1e8f2ce0ea..f06dd6bcfe4e818d10087032c97d3ce872c5453a 100644 (file)
@@ -12,6 +12,8 @@ define Image/BuildKernel
        $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
        dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
+       $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/vmlinux.64
+       md5sum  $(BIN_DIR)/vmlinux.64 | cut -d " " -f 1 | tee $(BIN_DIR)/vmlinux.64.md5
 endef
 
 define Image/Build/squashfs