rclone: Update to 1.60.0
authorTianling Shen <cnsztl@immortalwrt.org>
Mon, 31 Oct 2022 04:54:58 +0000 (12:54 +0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 31 Oct 2022 19:28:13 +0000 (12:28 -0700)
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
net/rclone/Makefile
net/rclone/patches/010-disable-plugins.patch

index 513108ec8d9e557a817bfec6cba1fc1c7f74641e..6a1ec2c2104bae7055210ddeb1f7ac3424287b1c 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rclone
-PKG_VERSION:=1.59.1
+PKG_VERSION:=1.60.0
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/rclone/rclone/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=3eb56502c49ffe53da0360b66d5c9ee6147433f1a9b0238686c1743855cc891f
+PKG_HASH:=357ee8bb1c1589d9640f1eb87ffeb9dbe8bc7ea6f33f90f56df142515a32f4f2
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILE:=LICENSE
index d404416a6d98c70c38c7342f7a883ddb702058f9..0b95f13b5ec704c98c21198af45af4c3a2003dcd 100644 (file)
@@ -1,14 +1,14 @@
 --- a/librclone/librclone.go
 +++ b/librclone/librclone.go
-@@ -37,7 +37,7 @@ import (
-       _ "github.com/rclone/rclone/backend/all"   // import all backends
+@@ -40,7 +40,7 @@ import (
+       _ "github.com/rclone/rclone/cmd/mount2"    // import mount2
        _ "github.com/rclone/rclone/fs/operations" // import operations/* rc commands
        _ "github.com/rclone/rclone/fs/sync"       // import sync/*
 -      _ "github.com/rclone/rclone/lib/plugin"    // import plugins
 +      // _ "github.com/rclone/rclone/lib/plugin"    // import plugins
-       _ "github.com/rclone/rclone/cmd/mount"     // import mount
-       _ "github.com/rclone/rclone/cmd/mount2"    // import mount2
-       _ "github.com/rclone/rclone/cmd/cmount"    // import cmount
+ )
+ // RcloneInitialize initializes rclone as a library
 --- a/rclone.go
 +++ b/rclone.go
 @@ -7,7 +7,7 @@ import (