gpgme: install gpgme-config to host bin
authorMatt Merhar <mattmerhar@protonmail.com>
Mon, 14 Dec 2020 02:24:54 +0000 (21:24 -0500)
committerMatt Merhar <mattmerhar@protonmail.com>
Mon, 14 Dec 2020 03:20:33 +0000 (22:20 -0500)
This is necessary for at least fwknop to properly detect the library.

The change was modeled after how gpg-error-config is installed in the
libgpg-error package.

Signed-off-by: Matt Merhar <mattmerhar@protonmail.com>
libs/gpgme/Makefile

index 1123f579a8236be70ae0657c3cd24c39d55463b1..da766a341464c504ecdf454bc5cd348582d0df95 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gpgme
 PKG_VERSION:=1.15.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://gnupg.org/ftp/gcrypt/$(PKG_NAME)
@@ -83,6 +83,15 @@ define Build/InstallDev
        $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/lib/cmake/Gpgmepp/*.cmake \
                $(1)/usr/lib/cmake/Gpgmepp
+
+       $(INSTALL_DIR) $(2)/bin $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/gpgme-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/gpgme-config
+       $(LN) -sf $(STAGING_DIR)/host/bin/gpgme-config $(1)/usr/bin/gpgme-config
 endef
 
 define Package/libgpgme/install