Disable NMRP support
authorRafał Miłecki <rafal@milecki.pl>
Thu, 3 Mar 2022 11:54:13 +0000 (12:54 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 3 Mar 2022 11:54:13 +0000 (12:54 +0100)
1. It's Netgear specific solution
2. It seems to deal with uImage legacy format only
3. It isn't clear if it can be actually used with BCM4908 images
4. It break Linux's support for Ethernet block (see below)

[   16.237263] Internal error: synchronous external abort: 96000210 [#1] SMP
[   16.244183] Modules linked in: pppoe ppp_async l2tp_ppp pptp pppox ppp_mppe ppp_generic iptable_nat ipt_REJECT xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_com8
[   16.244283]  nls_iso8859_1 nls_cp437 sha512_generic sha256_generic libsha256 sha1_generic seqiv jitterentropy_rng drbg md5 md4 hmac ecb des_generic libdes ctr cmac ccm arc4 usb_storage xhci_plat_hcd xhci_hcd ohci_platform ohci_hcd fsl_mph_dr_of ehci_platform ehci_fsl sd_mod scsi_mod ehci_hcd gpio_button_hotplug c
[   16.367770] CPU: 3 PID: 1933 Comm: netifd Not tainted 5.4.163 #0
[   16.373948] Hardware name: Luxul RT-20 (DT)
[   16.378251] pstate: 80400005 (Nzcv daif +PAN -UAO)
[   16.383185] pc : bcm4908_enet_open+0xa4/0x4a8
[   16.387658] lr : bcm4908_enet_open+0x78/0x4a8
[   16.392137] sp : ffffffc01238bb90
[   16.395541] x29: ffffffc01238bb90 x28: ffffff801f16da00
[   16.401007] x27: 0000000000000000 x26: ffffffc01238bda0
[   16.406472] x25: 0000000056000000 x24: 0000000000000000
[   16.411938] x23: ffffff801f193410 x22: ffffffc010412910
[   16.417403] x21: 0000000000000000 x20: ffffff801f05e840
[   16.422870] x19: ffffff801f05e000 x18: 0000000000000000
[   16.428335] x17: 0000000000000000 x16: 0000000000000000
[   16.433801] x15: 0000000000000000 x14: ffffffffffffffff
[   16.439266] x13: ffffff0000000000 x12: 0000000000000010
[   16.444731] x11: 0101010101010101 x10: ffffffff7f7f7f7f
[   16.450197] x9 : 0000000000000000 x8 : ffffff801d6986c0
[   16.455663] x7 : 0000000000000000 x6 : ffffff801d6985c8
[   16.461129] x5 : ffffff801d6985c8 x4 : ffffff801d698148
[   16.466594] x3 : 0000000000000000 x2 : ffffffc01007d414
[   16.472060] x1 : 00000000000005fc x0 : ffffffc01007d408
[   16.477527] Call trace:
[   16.480035]  bcm4908_enet_open+0xa4/0x4a8
[   16.484158]  __dev_open+0xcc/0x150
[   16.487651]  __dev_change_flags+0x134/0x198
[   16.491952]  dev_change_flags+0x20/0x60
[   16.495897]  dev_ifsioc+0x2d4/0x438
[   16.499478]  dev_ioctl+0x114/0x3a8
[   16.502976]  sock_ioctl+0x41c/0xda8
[   16.506560]  do_vfs_ioctl+0xa4/0xf78
[   16.510231]  ksys_ioctl+0x44/0x90
[   16.513636]  __arm64_sys_ioctl+0x1c/0x1c0
[   16.517761]  el0_svc_handler+0xd4/0x130
[   16.521701]  el0_svc+0x8/0x208
[   16.524839] Code: f9442a60 91105002 b9000041 91102000 (b9400000)
[   16.531108] ---[ end trace f89da5ffee613fd6 ]---
[   16.535857] Kernel panic - not syncing: Fatal exception

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
config.mk
net/Makefile

index 46eca2d7dc92b0dc0700cf0c401a3b7d3ff9a2e9..ea142d709e564baab3116647ae824cf2222df52b 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -73,7 +73,7 @@ PLATFORM_CPPFLAGS += -pipe
 LDFLAGS += $(PLATFORM_LDFLAGS)
 LDFLAGS_FINAL += -Bstatic
 
-PLATFORM_CPPFLAGS += -DFIRMWARE_RECOVER_FROM_TFTP_SERVER -DCONFIG_SYS_NMRP -DDNI_NAND -DCONFIG_SYS_SINGLE_FIRMWARE
+PLATFORM_CPPFLAGS += -DDNI_NAND -DCONFIG_SYS_SINGLE_FIRMWARE
 
 export PLATFORM_CPPFLAGS
 export RELFLAGS
index f680e5d88db239cdf510eda067e728f73349becf..64219f0b60ceb73ac02d5b5d78306cc50c17210e 100644 (file)
@@ -25,7 +25,7 @@ obj-$(CONFIG_CMD_SNTP) += sntp.o
 obj-$(CONFIG_CMD_TFTPBOOT) += tftp.o
 obj-$(CONFIG_UDP_FUNCTION_FASTBOOT)  += fastboot.o
 obj-$(CONFIG_CMD_WOL)  += wol.o
-obj- += nmrp.o
+obj-$(CONFIG_SYS_NMRP) += nmrp.o
 
 # Disable this warning as it is triggered by:
 # sprintf(buf, index ? "foo%d" : "foo", index)