[packages] transmission: cleanup and drop some bashizm
authorCezary Jackiewicz <cezary@eko.one.pl>
Sun, 13 Nov 2011 06:45:40 +0000 (06:45 +0000)
committerCezary Jackiewicz <cezary@eko.one.pl>
Sun, 13 Nov 2011 06:45:40 +0000 (06:45 +0000)
SVN-Revision: 29006

net/transmission/Makefile
net/transmission/files/transmission.init

index f97843afb2f1ab0cb3e2d2ab33c0296ac42392c6..45f84b930bb0f1fcdc4ade15e810b1c6e90669a0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
 PKG_VERSION:=2.42
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
index e4accc1a284629ab2458c5ae3ec3fc1d33aa4269..a3c50212f7cf83ba5393755599c672dc99442098 100644 (file)
@@ -37,11 +37,10 @@ append_params_quotes() {
 
 start_service() {
        local s="$1"
-       local enable=0
        local enabled=0
        local run_as_usr='root'
        local open_file_limit=0
-       local ulimit_files=`ulimit -n`
+       local ulimit_files=$(ulimit -n)
 
        # disabled?
        config_get_bool enabled "$s" enabled 0
@@ -81,7 +80,7 @@ start_service() {
        chown -R $run_as_usr $config_dir
 
        config_get open_file_limit "$s" open_file_limit 32
-       let open_limit_files="$open_file_limit + 8"
+       open_limit_files=$(($open_file_limit + 8))
 
        if [ ${open_file_limit} -gt ${ulimit_files} ]; then
                ulimit -n $open_limit_files