shadowsocks-libev: fix compat issue with newer version of ucode
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 28 Apr 2022 03:09:51 +0000 (03:09 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 28 Apr 2022 03:11:06 +0000 (03:11 +0000)
Link: https://github.com/openwrt/packages/issues/18393
Reported-by: Huangbin Zhan <zhanhb88@gmail.com>
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/shadowsocks-libev/Makefile
net/shadowsocks-libev/files/shadowsocks-libev.init

index 1a76d67fe1ff9258710ad545ead7f4f106bb610b..7ef1706d3d167f359ca3b26f0d1a67d0afd0641c 100644 (file)
@@ -14,7 +14,7 @@ include $(TOPDIR)/rules.mk
 #
 PKG_NAME:=shadowsocks-libev
 PKG_VERSION:=3.3.5
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/shadowsocks/shadowsocks-libev/releases/download/v$(PKG_VERSION)
index be72a9f66482c8d59f0f9e163034dc949ef9c91c..d0bfde71f4ab8bee7865f47e20d64257b9744be4 100644 (file)
@@ -156,7 +156,7 @@ ss_rules() {
        json_add_string o_nft_udp_extra "$nft_udp_extra"
        json_dump -i >"$tmp.json"
 
-       if ucode -S -i "$ssrules_uc" -E "$tmp.json" >"$tmp.nft" \
+       if utpl -S -F "$tmp.json" "$ssrules_uc" >"$tmp.nft" \
                && ! cmp -s "$tmp.nft" "$ssrules_nft"; then
                echo "table inet chk {include \"$tmp.nft\";}" >"$tmp.nft.chk"
                if nft -f "$tmp.nft.chk" -c; then