mpd: Update to 0.18.23, fix ALSA support in mpd-mini, refresh patches
authorTed Hess <thess@kitschensync.net>
Tue, 12 May 2015 19:16:07 +0000 (15:16 -0400)
committerTed Hess <thess@kitschensync.net>
Tue, 12 May 2015 19:16:07 +0000 (15:16 -0400)
Signed-off-by: Ted Hess <thess@kitschensync.net>
sound/mpd/Makefile
sound/mpd/patches/210-support_raw_pcm_streams.patch
sound/mpd/patches/220-handle_slow_server_stream_startup.patch

index 1b1e8686e67b80ad8079ecd4e832d779d4691677..56e63eb4afed85720015ca3f7c757aff1740c85b 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.18.21
+PKG_VERSION:=0.18.23
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.18/
-PKG_MD5SUM:=945879f55acc256d30a5f69787338ceb
+PKG_MD5SUM:=fcdfe8b3a7a21a87b6776204e6eb7814
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 
 PKG_LICENSE:=GPL-2.0
@@ -161,7 +161,6 @@ ifeq ($(BUILD_VARIANT),full)
 
   CONFIGURE_ARGS += \
        $(call autoconf_bool,CONFIG_BUILD_PATENTED,aac) \
-       $(call autoconf_bool,CONFIG_AUDIO_SUPPORT,alsa) \
        --enable-audiofile \
        --enable-fifo \
        --enable-ffmpeg \
@@ -185,7 +184,6 @@ ifeq ($(BUILD_VARIANT),mini)
   # oggflac is not compatible with tremor
   CONFIGURE_ARGS += \
        --disable-aac \
-       --disable-alsa \
        --disable-audiofile \
        --disable-fifo \
        --disable-ffmpeg \
index 2fe086babf2bb7a006c1f5b928ea79279d855e2d..f6624af18f9481d866bec5be7ba7270cf4def041 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/decoder/FfmpegDecoderPlugin.cxx
 +++ b/src/decoder/FfmpegDecoderPlugin.cxx
-@@ -634,6 +634,7 @@ static const char *const ffmpeg_mime_typ
+@@ -666,6 +666,7 @@ static const char *const ffmpeg_mime_typ
        "audio/qcelp",
        "audio/vorbis",
        "audio/vorbis+ogg",
index 2c25c33e62506c4a46a319f5a8bb0e8ea2e4b611..af2773d06ebe6aa1d2f693a2f119b10747218347 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/decoder/FfmpegDecoderPlugin.cxx
 +++ b/src/decoder/FfmpegDecoderPlugin.cxx
-@@ -373,6 +373,13 @@ ffmpeg_probe(Decoder *decoder, InputStre
+@@ -376,6 +376,13 @@ ffmpeg_probe(Decoder *decoder, InputStre
  
        unsigned char buffer[BUFFER_SIZE];
        size_t nbytes = decoder_read(decoder, is, buffer, BUFFER_SIZE);