iperf: use uclibc++.mk
authorFelix Fietkau <nbd@openwrt.org>
Thu, 14 Jun 2012 20:26:23 +0000 (20:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 14 Jun 2012 20:26:23 +0000 (20:26 +0000)
SVN-Revision: 32372

net/iperf/Makefile

index b1bd59f809383b06788dd86fe5261b129268f276..34a029fd48150398b9251d065342dcaa4e27bf7c 100644 (file)
@@ -18,12 +18,13 @@ PKG_MD5SUM:=44b5536b67719f4250faed632a3cd016
 
 PKG_BUILD_PARALLEL:=1
 
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/iperf/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:= +uclibcxx
+  DEPENDS:= $(CXX_DEPENDS)
   TITLE:=Internet Protocol bandwidth measuring tool
   URL:=http://sourceforge.net/projects/iperf/
 endef
@@ -67,8 +68,6 @@ else
   CONFIGURE_VARS += ac_cv_func_pthread_cancel=no
 endif
 
-TARGET_CXX=g++-uc
-
 CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-rtti"
 
 ifeq ($(BUILD_VARIANT),mt)