db47: Force pthread mutexes, bump PKG_RELEASE
authorMarcel Denia <naoir@gmx.net>
Thu, 28 May 2015 21:02:43 +0000 (23:02 +0200)
committerMarcel Denia <naoir@gmx.net>
Sun, 31 May 2015 11:40:26 +0000 (13:40 +0200)
Fixes #1312.

Signed-off-by: Marcel Denia <naoir@gmx.net>
libs/db47/Makefile

index 563d47c881ae4d146fb34fb5a0344634e10f1625..113964a503822ad0dda2825514a3c01252e2c300 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2014 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,7 @@ BASE_VERSION:=4.7.25
 
 PKG_NAME:=db47
 PKG_VERSION:=$(BASE_VERSION).4.NC
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/db-$(BASE_VERSION).NC
 PKG_SOURCE:=db-$(BASE_VERSION).NC.tar.gz
@@ -62,7 +62,7 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-java \
-       --with-mutex=UNIX/fcntl \
+       --with-mutex=POSIX/pthreads/library \
        --disable-tcl \
        --disable-rpc \
        --enable-compat185 \