ipq40xx: use ath10k-ct-smallbuffers for 128 MiB devices
authorPaul Fertser <fercerpav@gmail.com>
Tue, 24 Dec 2019 17:49:10 +0000 (20:49 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 26 Dec 2019 15:19:58 +0000 (16:19 +0100)
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
(cherry picked from commit 0b7d779dcfc57507ab1d06ce6f1052d25e9de017)

target/linux/ipq40xx/image/Makefile

index 99bdf809df76d05e1461c92b87e43d4f86c0dd2a..98c81726d9c12bd466df2150c3e98a76cfb46f78 100644 (file)
@@ -110,7 +110,8 @@ define Device/asus_rt-ac58u
 #      string and call it a day.... Yeah, we do the latter!
        UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC58U')
        IMAGES := sysupgrade.bin
-       DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
+       DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
+               kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += asus_rt-ac58u
 
@@ -413,6 +414,7 @@ define Device/zyxel_wre6606
        DEVICE_DTS := qcom-ipq4018-wre6606
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += zyxel_wre6606