python: use Build/Prepare rule for the config.site file 566/head
authorAlexandru Ardelean <aa@ocedo.com>
Wed, 26 Nov 2014 08:04:06 +0000 (10:04 +0200)
committerAlexandru Ardelean <aa@ocedo.com>
Wed, 26 Nov 2014 09:51:40 +0000 (11:51 +0200)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/Makefile

index 39a1da622ac9a8c63626e07121b8a012da4a2676..92271ba9fc159867a64a8c8fdf2115c57abb041c 100644 (file)
@@ -97,13 +97,11 @@ CONFIGURE_ARGS+= \
        CONFIG_SITE="$(PKG_BUILD_DIR)/config.site" \
        OPT="$(TARGET_CFLAGS)"
 
-define Hooks/Configure/Pre/ConfigSiteInstall
+define Build/Prepare
+       $(call Build/Prepare/Default)
        $(CP) ./files/config.site $(PKG_BUILD_DIR)/config.site
 endef
 
-Hooks/Configure/Pre+=\
-       Hooks/Configure/Pre/ConfigSiteInstall
-
 define Build/InstallDev
        $(INSTALL_DIR) $(STAGING_DIR)/mk/
        $(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/