simplify openldap makefile and make it build on osx
authorFelix Fietkau <nbd@openwrt.org>
Sun, 1 Apr 2007 18:52:18 +0000 (18:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 1 Apr 2007 18:52:18 +0000 (18:52 +0000)
SVN-Revision: 6806

libs/openldap/Makefile
libs/openldap/patches/500-cross-compile.patch

index 4068800304efa7ea1fa792225eb442ffdbd0b343..1e8e215cea08b499d1e3762ac6e86ba973a75347 100644 (file)
@@ -59,7 +59,7 @@ define Package/openldap-utils
     This package contains client programs required to access LDAP servers.
 endef
 
-PKG_CONFIGURE_OPTIONS = \
+CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-debug \
@@ -73,76 +73,16 @@ PKG_CONFIGURE_OPTIONS = \
        --with-threads \
        --with-tls \
        --with-yielding_select="yes" \
+       --without-cyrus-sasl \
+       --without-threads \
+       --without-tls 
 
-define Build/Configure
-endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       -$(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               distclean
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               ./configure \
-                       --target=$(GNU_HOST_NAME) \
-                       --host=$(GNU_HOST_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       $(PKG_CONFIGURE_OPTIONS) \
-                       --without-cyrus-sasl \
-                       --without-threads \
-                       --without-tls \
-       );
-       $(MAKE) -C $(PKG_BUILD_DIR) depend 
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblutil
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblber
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblunicode
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblber clean
-       $(MAKE) -C $(PKG_BUILD_DIR)/libraries/liblutil clean
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib " \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       $(PKG_CONFIGURE_OPTIONS) \
-       );
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+               HOSTCC="$(HOSTCC)" \
+               depend all install
 endef
 
 define Build/InstallDev
index d0aafdcd76659046af495f970bf46d45683454e4..6451478f24128a6a5f26a53312f9c01b9e0212ce 100644 (file)
@@ -1,12 +1,26 @@
 diff -ruN openldap-2.2.26-orig/libraries/liblunicode/Makefile.in openldap-2.2.26-1/libraries/liblunicode/Makefile.in
 --- openldap-2.2.26-orig/libraries/liblunicode/Makefile.in     2005-01-20 18:01:03.000000000 +0100
 +++ openldap-2.2.26-1/libraries/liblunicode/Makefile.in        2005-05-08 15:47:08.000000000 +0200
-@@ -29,7 +29,7 @@
+@@ -29,8 +29,8 @@
  LDAP_INCDIR= ../../include       
  LDAP_LIBDIR= ../../libraries
  
 -ucgendat: $(XLIBS) ucgendat.o
-+ucgendat: ucgendat.o
-       $(LTLINK) -o $@ ucgendat.o $(LIBS)
+-      $(LTLINK) -o $@ ucgendat.o $(LIBS)
++ucgendat:
++      $(HOSTCC) -I$(LDAP_INCDIR) -o $@ ./ucdata/ucgendat.c
        ./ucgendat $(srcdir)/UnicodeData.txt -x $(srcdir)/CompositionExclusions.txt
  
+ DATFILES = case.dat cmbcl.dat comp.dat ctype.dat decomp.dat num.dat kdecomp.dat
+diff -ur openldap.old/libraries/liblunicode/ucdata/ucgendat.c openldap.dev/libraries/liblunicode/ucdata/ucgendat.c
+--- openldap.old/libraries/liblunicode/ucdata/ucgendat.c       2005-01-20 18:01:03.000000000 +0100
++++ openldap.dev/libraries/liblunicode/ucdata/ucgendat.c       2007-04-01 20:35:57.000000000 +0200
+@@ -1611,7 +1611,7 @@
+     FILE *in;
+     char *prog, *opath;
+-    prog = lutil_progname( "ucgendat", argc, argv );
++    prog = argv[0];
+     opath = 0;
+     in = stdin;