asterisk-13.x: remove sounds cache
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 21 May 2018 20:56:30 +0000 (22:56 +0200)
committerSebastian Kemper <sebastian_ml@gmx.net>
Mon, 21 May 2018 21:09:26 +0000 (23:09 +0200)
When there is no sounds cache declared the build system will not attempt to
download any sound packs or their SHA1 checksums.

This is to be preferred because:

  a) the build may occur offline, causing it to fail
  b) plain http is used by the build system for downloading

There is no drawback here because the standard sound packs are included in
the Asterisk source tarball already.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/asterisk-13.x/Makefile

index 54df5cc3acb4da0559cc828a947164659ca54c58..a268288b572264d679a31d6ec2820af86cd97dbb 100644 (file)
@@ -551,8 +551,7 @@ CONFIGURE_ARGS+= \
        --without-tinfo \
        $(if $(CONFIG_PACKAGE_$(PKG_NAME)-format-ogg-vorbis),--with-vorbis="$(STAGING_DIR)/usr",--without-vorbis) \
        --without-vpb \
-       --with-z="$(STAGING_DIR)/usr" \
-       --with-sounds-cache="$(DL_DIR)"
+       --with-z="$(STAGING_DIR)/usr"
 
 ifeq ($(CONFIG_PACKAGE_$(PKG_NAME)-codec-speex)$(CONFIG_PACKAGE_$(PKG_NAME)-func-speex),)
 CONFIGURE_ARGS+= \