[package] update darkstat to 3.0.712 (#5535)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 17 Jul 2009 11:09:40 +0000 (11:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 17 Jul 2009 11:09:40 +0000 (11:09 +0000)
SVN-Revision: 16873

net/darkstat/Makefile
net/darkstat/files/darkstat.init

index 469ad94e4a8c64e93fac6a8f137f157d7658cd2e..3abc3b460d621e31adf32b525027eba4dccf5353 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=darkstat
-PKG_VERSION:=3.0.708
+PKG_VERSION:=3.0.712
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://dmr.ath.cx/net/darkstat
-PKG_MD5SUM:=21fe231f6ec84be082e9d41747dd0fc9
+PKG_MD5SUM:=b711f64319091d6948a05bc33a4954b3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,6 +31,10 @@ define Package/darkstat/description
        and serves them over HTTP.
 endef
 
+define Package/darkstat/conffiles
+/etc/config/darkstat
+endef
+
 CONFIGURE_ARGS += \
        --with-chroot-dir /var/empty
 
@@ -49,7 +53,7 @@ define Package/darkstat/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/darkstat.init $(1)/etc/init.d/darkstat
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/darkstat.conf $(1)/etc/config/darkstat
+       $(INSTALL_CONF) ./files/darkstat.conf $(1)/etc/config/darkstat
 endef
 
 $(eval $(call BuildPackage,darkstat))
index 4f322688afc25dfcf01896ffd311451f29aa99a7..11d70288db13cdcb24f545cfb6be07c0dd6ed98e 100644 (file)
@@ -22,7 +22,7 @@ start_darkstat() {
        scan_interfaces
        config_get ifname "$interface" ifname
 
-       $BIN --debug -i "$interface" \
+       $BIN --verbose -i "$interface" \
                ${httpaddr:+-b "$httpaddr"} \
                ${httpport:+-p "$httpport"} \
                --chroot $RUN_D