fossl: update to 1.34
authorLuka Perkov <luka@openwrt.org>
Wed, 4 Nov 2015 20:44:03 +0000 (21:44 +0100)
committerLuka Perkov <luka@openwrt.org>
Wed, 4 Nov 2015 21:46:58 +0000 (22:46 +0100)
Signed-off-by: Luka Perkov <luka@openwrt.org>
net/fossil/Makefile
net/fossil/patches/001-no_https.patch [new file with mode: 0644]
net/fossil/patches/no_https.patch [deleted file]

index 656c83ccbc4b93ca789d303672ef20eb2603de7a..687c7997cb58b082af171953372cff5ba2fc3599 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fossil
-PKG_VERSION:=1.33
+PKG_VERSION:=1.34
 PKG_RELEASE:=1
 
 PKG_LICENSE:=BSD-2-Clause
@@ -16,7 +16,7 @@ PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
 PKG_SOURCE:=$(PKG_NAME)-src-${PKG_VERSION}.tar.gz
 PKG_SOURCE_URL:=http://www.fossil-scm.org/download/
-PKG_MD5SUM:=53f8145084a2065d6cb734980c172c7e
+PKG_MD5SUM:=3d5a7da5c506a47784942236a788b29b
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-src-$(PKG_VERSION)
 
diff --git a/net/fossil/patches/001-no_https.patch b/net/fossil/patches/001-no_https.patch
new file mode 100644 (file)
index 0000000..cd83ffa
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/Makefile.classic
++++ b/Makefile.classic
+@@ -41,9 +41,6 @@
+ # FOSSIL_ENABLE_MINIZ = 1
+ # TCC += -DFOSSIL_ENABLE_MINIZ
+-# To add support for HTTPS
+-TCC += -DFOSSIL_ENABLE_SSL
+-
+ #### We sometimes add the -static option here so that we can build a
+ #    static executable that will run in a chroot jail.
+ #LIB = -static
+@@ -60,9 +57,6 @@
+ # If using zlib:
+ LIB += $(ZLIB_LIB.$(FOSSIL_ENABLE_MINIZ)) $(LDFLAGS)
+-# If using HTTPS:
+-LIB += -lcrypto -lssl
+-
+ #### Tcl shell for use in running the fossil testsuite.  If you do not
+ #    care about testing the end result, this can be blank.
+ #
diff --git a/net/fossil/patches/no_https.patch b/net/fossil/patches/no_https.patch
deleted file mode 100644 (file)
index 411504f..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/Makefile.classic
-+++ b/Makefile.classic
-@@ -41,9 +41,6 @@ TCC = gcc -g -Os -Wall
- # FOSSIL_ENABLE_MINIZ = 1
- # TCC += -DFOSSIL_ENABLE_MINIZ
--# To add support for HTTPS
--TCC += -DFOSSIL_ENABLE_SSL
--
- #### Extra arguments for linking the finished binary.  Fossil needs
- #    to link against the Z-Lib compression library unless the miniz
- #    library in the source tree is being used.  There are no other
-@@ -58,9 +55,6 @@ ZLIB_LIB.  = $(ZLIB_LIB.0)
- # If using zlib:
- LIB = $(ZLIB_LIB.$(FOSSIL_ENABLE_MINIZ)) $(LDFLAGS)
--# If using HTTPS:
--LIB += -lcrypto -lssl
--
- #### Tcl shell for use in running the fossil testsuite.  If you do not
- #    care about testing the end result, this can be blank.
- #