squashfs-tools: build with xz by default
authorDaniel Golle <daniel@makrotopia.org>
Sat, 15 May 2021 23:08:05 +0000 (00:08 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 13 Jun 2021 21:39:14 +0000 (22:39 +0100)
squashfs-tools aren't of much use without xz compression support
on OpenWrt, as we build kernel with squashfs supporting only xz.
Enabled support for xz compression by default.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
utils/squashfs-tools/Config.in
utils/squashfs-tools/Makefile

index 6d556700fc9006b93ac07870e077d158a4c52b39..ebe09147bb237d016fda32b108b684a2cc3ba448 100644 (file)
@@ -14,7 +14,7 @@ config SQUASHFS_TOOLS_XZ_SUPPORT
        depends on PACKAGE_squashfs-tools-mksquashfs || PACKAGE_squashfs-tools-unsquashfs
        bool "Enable XZ support"
        select PACKAGE_liblzma
-       default n
+       default y
 
 config SQUASHFS_TOOLS_ZSTD_SUPPORT
        depends on PACKAGE_squashfs-tools-mksquashfs || PACKAGE_squashfs-tools-unsquashfs
index 19da23384c40e20f5a23961ff165b76ea91aacd2..687fc413430ff90e7d401c08dad9231fe6890ea9 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squashfs-tools
 PKG_VERSION:=4.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_LICENSE:=GPL-2.0-only
 PKG_LICENSE_FILES:=COPYING