dockerd: busybox compatibility 22130/head
authorOskari Rauta <oskari.rauta@gmail.com>
Sun, 17 Sep 2023 13:36:27 +0000 (16:36 +0300)
committerOskari Rauta <oskari.rauta@gmail.com>
Sun, 17 Sep 2023 13:36:30 +0000 (16:36 +0300)
build hosts with busybox fail with long options on rm
command. Short versions are supported by all, so this
makes it script compatible with busybox hosts as well.

Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
utils/dockerd/Makefile
utils/dockerd/git-short-commit.sh

index fb09299036b44f0501cadb70386397297e111e8f..d5b455c794fd9d31b7631251be570cb24850d59c 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dockerd
 PKG_VERSION:=24.0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
index ea8611ba5779c6c6010d05bbae3f205c2e7632eb..650ab8c82d76d460293c60d7fca52aecab911fcc 100755 (executable)
@@ -26,7 +26,7 @@ if [ -z "${GIT_DIR}" ]; then
 fi
 
 clean_up() {
-       rm --force --recursive "${GIT_DIR}"
+       rm -rf "${GIT_DIR}"
 }
 trap clean_up EXIT