mac80211: fix reversed WARN_ON() condition which causes a stray stacktrace on boot
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 21 Nov 2011 13:33:11 +0000 (13:33 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 21 Nov 2011 13:33:11 +0000 (13:33 +0000)
SVN-Revision: 29284

package/mac80211/Makefile
package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch [new file with mode: 0644]

index 25df7aa319f7e4f603bc528ebcb7b6b0588ff2bc..aa729414a229e35721effe587fabb0b931efbad3 100644 (file)
@@ -40,6 +40,8 @@ PKG_CONFIG_DEPENDS:= \
 
 CARL9170_FW_VERSION:=1.9.4
 
+#QUILT_PATCH_DIR:=patches-openwrt
+
 include $(INCLUDE_DIR)/package.mk
 
 WMENU:=Wireless Drivers
diff --git a/package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch b/package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch
new file mode 100644 (file)
index 0000000..b598574
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/compat/compat-2.6.36.c
++++ b/compat/compat-2.6.36.c
+@@ -101,7 +101,7 @@ EXPORT_SYMBOL_GPL(system_nrt_wq);
+ void compat_system_workqueue_create()
+ {
+       system_nrt_wq = create_singlethread_workqueue("events_nrt");
+-      WARN_ON(system_nrt_wq);
++      WARN_ON(!system_nrt_wq);
+ }
+ void compat_system_workqueue_destroy()