Add lxde packages.
authorLars-Peter Clausen <lars@metafoo.de>
Sun, 8 Feb 2009 14:08:58 +0000 (14:08 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Sun, 8 Feb 2009 14:08:58 +0000 (14:08 +0000)
SVN-Revision: 14445

12 files changed:
lxde/apps/lxappearance/Makefile [new file with mode: 0644]
lxde/apps/lxpanel/Makefile [new file with mode: 0644]
lxde/apps/lxrandr/Makefile [new file with mode: 0644]
lxde/apps/lxsession-edit/Makefile [new file with mode: 0644]
lxde/apps/lxsession-lite/Makefile [new file with mode: 0644]
lxde/apps/lxshortcut/Makefile [new file with mode: 0644]
lxde/apps/lxtask/Makefile [new file with mode: 0644]
lxde/apps/lxterminal/Makefile [new file with mode: 0644]
lxde/apps/pcmanfm/Makefile [new file with mode: 0644]
lxde/data/lxde-common/Makefile [new file with mode: 0644]
lxde/data/lxmenu-data/Makefile [new file with mode: 0644]
lxde/libs/libmenu-cache/Makefile [new file with mode: 0644]

diff --git a/lxde/apps/lxappearance/Makefile b/lxde/apps/lxappearance/Makefile
new file mode 100644 (file)
index 0000000..bed4a58
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxappearance
+PKG_VERSION:=0.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=28e436c13ab09af54ffc6b415407ca37
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+    -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+    -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxappearance
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxappearance
+  DEPENDS:=+glib2 +vte +lxde-common
+endef
+
+define Package/lxappearance/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/lxappearance \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share/{lxappearance,applications}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/lxappearance/* \
+               $(1)/usr/share/lxappearance/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/applications/* \
+               $(1)/usr/share/applications
+endef
+
+$(eval $(call BuildPackage,lxappearance))
diff --git a/lxde/apps/lxpanel/Makefile b/lxde/apps/lxpanel/Makefile
new file mode 100644 (file)
index 0000000..fd327ff
--- /dev/null
@@ -0,0 +1,63 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxpanel
+PKG_VERSION:=0.3.99
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=91f020d385ee29dcfff820d5c77a0e4f
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+       -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+       -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxpanel
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxpanel
+  DEPENDS:=+gtk2 +libmenu-cache +libiw +lxde-common
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --with-plugis=all \
+       )
+endef
+
+define Package/lxpanel/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/lxpanel* \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/lib/lxpanel/plugins
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/lxpanel/plugins/*.so \
+               $(1)/usr/lib/lxpanel/plugins/
+
+       $(INSTALL_DIR) $(1)/usr/share/lxpanel
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/share/lxpanel/* \
+               $(1)/usr/share/lxpanel/
+endef
+
+$(eval $(call BuildPackage,lxpanel))
diff --git a/lxde/apps/lxrandr/Makefile b/lxde/apps/lxrandr/Makefile
new file mode 100644 (file)
index 0000000..3ede3cf
--- /dev/null
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxrandr
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=d70a41f0230a1b528d66015021b8fa0d
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+    -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+    -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxrandr
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxrandr
+  DEPENDS:=+gtk2 +xrandr +lxde-common
+endef
+
+define Package/lxrandr/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/lxrandr \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share/applications
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/applications/* \
+               $(1)/usr/share/applications/
+endef
+
+$(eval $(call BuildPackage,lxrandr))
diff --git a/lxde/apps/lxsession-edit/Makefile b/lxde/apps/lxsession-edit/Makefile
new file mode 100644 (file)
index 0000000..3d1742b
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxsession-edit
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=1035b7e5b4edb96332df8ffd14bb9359
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+    -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+    -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxsession-edit
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxsession-edit
+  DEPENDS:=+gtk2
+endef
+
+define Package/lxsession-edit/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/lxsession-edit \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share/{lxsession-edit,applications}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/lxsession-edit/* \
+               $(1)/usr/share/lxsession-edit/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/applications/* \
+               $(1)/usr/share/applications
+endef
+
+$(eval $(call BuildPackage,lxsession-edit))
diff --git a/lxde/apps/lxsession-lite/Makefile b/lxde/apps/lxsession-lite/Makefile
new file mode 100644 (file)
index 0000000..975d13e
--- /dev/null
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxsession-lite
+PKG_VERSION:=0.3.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=909c3b0f4c6e4855f64dfbb47467c0b3
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+    -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+    -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxsession-lite
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxsession-lite
+  DEPENDS:=+glib2 +vte
+endef
+
+define Package/lxsession-lite/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/lxsession{,-logout} \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share/lxsession/images
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/lxsession/images/* \
+               $(1)/usr/share/lxsession/images/
+
+endef
+
+$(eval $(call BuildPackage,lxsession-lite))
diff --git a/lxde/apps/lxshortcut/Makefile b/lxde/apps/lxshortcut/Makefile
new file mode 100644 (file)
index 0000000..dcae15b
--- /dev/null
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxshortcut
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=63d1d0a4706b580d819b4d51fa057b25
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+    -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+    -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxshortcut
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxshortcut
+  DEPENDS:=+glib2 +vte
+endef
+
+define Package/lxshortcut/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/lxshortcut \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share/lxshortcut
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/lxshortcut/* \
+               $(1)/usr/share/lxshortcut/
+
+endef
+
+$(eval $(call BuildPackage,lxshortcut))
diff --git a/lxde/apps/lxtask/Makefile b/lxde/apps/lxtask/Makefile
new file mode 100644 (file)
index 0000000..15b6e83
--- /dev/null
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxtask
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=e69b31ea8169bcf1d9b0c40c06a6e782
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+    -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+    -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxtask
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxtask
+  DEPENDS:=+gtk2 +lxde-common
+endef
+
+define Package/lxtask/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/lxtask \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share/applications
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/applications/* \
+               $(1)/usr/share/applications
+endef
+
+$(eval $(call BuildPackage,lxtask))
diff --git a/lxde/apps/lxterminal/Makefile b/lxde/apps/lxterminal/Makefile
new file mode 100644 (file)
index 0000000..ac4aad7
--- /dev/null
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxterminal
+PKG_VERSION:=0.1.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=996ca3002531a0f251ca06856d32b53b
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+    -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+    -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxterminal
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxterminal
+  DEPENDS:=+glib2 +vte +lxde-common
+endef
+
+define Package/lxterminal/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/lxterminal \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share/{lxterminal,applications,pixmaps}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/lxterminal/* \
+               $(1)/usr/share/lxterminal/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/applications/* \
+               $(1)/usr/share/applications
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/pixmaps/* \
+               $(1)/usr/share/pixmaps/
+
+endef
+
+$(eval $(call BuildPackage,lxterminal))
diff --git a/lxde/apps/pcmanfm/Makefile b/lxde/apps/pcmanfm/Makefile
new file mode 100644 (file)
index 0000000..5f40c15
--- /dev/null
@@ -0,0 +1,75 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pcmanfm
+PKG_VERSION:=0.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/pcmanfm
+PKG_MD5SUM:=fe1a836eed6a42107e7d71a01a52f7ec
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib
+
+define Package/pcmanfm
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=pcmanfm
+  DEPENDS:=+gtk2
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+           --disable-hal \
+       )
+endef
+
+define Package/pcmanfm/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/pcmanfm \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share/{mime/packages,applications,pixmaps}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/mime/packages/* \
+               $(1)/usr/share/mime/packages
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/applications/* \
+               $(1)/usr/share/applications
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/pixmaps/* \
+               $(1)/usr/share/pixmaps/
+
+       $(INSTALL_DIR) $(1)/usr/share/pcmanfm/{icons,ui}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/pcmanfm/*.rules \
+               $(1)/usr/share/pcmanfm/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/pcmanfm/icons/* \
+               $(1)/usr/share/pcmanfm/icons/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/pcmanfm/ui/* \
+               $(1)/usr/share/pcmanfm/ui/
+
+endef
+
+$(eval $(call BuildPackage,pcmanfm))
diff --git a/lxde/data/lxde-common/Makefile b/lxde/data/lxde-common/Makefile
new file mode 100644 (file)
index 0000000..c76c006
--- /dev/null
@@ -0,0 +1,57 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxde-common
+PKG_VERSION:=0.3.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=f30eee998071ace04e7be33aa8ac6a5b
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+       -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+       -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxde-common
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxde-common
+  DEPENDS:=+smproxy +openbox +lxsession-lite +hicolor-icon-theme
+endef
+
+define Package/lxde-common/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/* \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/share
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/share/* \
+               $(1)/usr/share/
+
+       $(INSTALL_DIR) $(1)/etc/xdg/lxsession/LXDE
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/etc/xdg/lxsession/LXDE/* \
+               $(1)/etc/xdg/lxsession/LXDE/
+endef
+
+$(eval $(call BuildPackage,lxde-common))
diff --git a/lxde/data/lxmenu-data/Makefile b/lxde/data/lxmenu-data/Makefile
new file mode 100644 (file)
index 0000000..5695a93
--- /dev/null
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lxmenu-data
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=1c35ad4bf05cd076ce4a9bb64a246351
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS+= \
+       -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+       -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/lxmenu-data
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=lxmenu-data
+endef
+
+define Package/lxmenu-data/install
+       $(INSTALL_DIR) $(1)/usr/share/desktop-directories
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/desktop-directories/* \
+               $(1)/usr/share/desktop-directories/
+
+       $(INSTALL_DIR) $(1)/etc/xdg/menus
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/etc/xdg/menus/* \
+               $(1)/etc/xdg/menus/
+endef
+
+$(eval $(call BuildPackage,lxmenu-data))
diff --git a/lxde/libs/libmenu-cache/Makefile b/lxde/libs/libmenu-cache/Makefile
new file mode 100644 (file)
index 0000000..1ce1c38
--- /dev/null
@@ -0,0 +1,66 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=menu-cache
+PKG_VERSION:=0.2.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lxde
+PKG_MD5SUM:=
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+PKG_INSTALL=1
+
+TARGET_CFLAGS+= \
+       -I$(STAGING_DIR)/usr/lib/libintl/include/ \
+       -I$(STAGING_DIR)/usr/lib/libiconv/include/
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -L$(STAGING_DIR)/usr/lib/libintl/lib \
+       -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/libmenu-cache
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=libmenu-cache
+  DEPENDS:=+glib2
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/menu-cache}
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/menu-cache/*.h \
+               $(1)/usr/include/menu-cache/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
+               $(1)/usr/lib/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libmenu-cache/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/menu-{cached,cache-gen} \
+               $(1)/usr/bin
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libmenu-cache))