zerotier: update to release 1.4.4 9903/head
authorMoritz Warning <moritzwarning@web.de>
Mon, 2 Sep 2019 01:48:44 +0000 (03:48 +0200)
committerMoritz Warning <moritzwarning@web.de>
Tue, 3 Sep 2019 13:14:27 +0000 (15:14 +0200)
Also allow path to local.conf to be set and enable linker optimisations
to save a few bytes.

Signed-off-by: Moritz Warning <moritzwarning@web.de>
net/zerotier/Makefile
net/zerotier/files/etc/config/zerotier
net/zerotier/files/etc/init.d/zerotier

index 4a69d5e6b46d5a8a66598803599a358a7d9e32a2..1ccb21bfd376f404fe631b128d54e7abc2cd8fdb 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zerotier
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=557a444127812384265ec97232bae43dce1d4b1545ddd72e2b1646c971dad7c5
+PKG_HASH:=0c11aab77b1c30fb8932e31906fc93fe7cb38c579c33740c1d407ec13d5b3e12
 PKG_BUILD_DIR:=$(BUILD_DIR)/ZeroTierOne-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
@@ -54,7 +54,7 @@ endef
 
 # Make binary smaller
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
 
 ifdef CONFIG_USE_UCLIBC
        TARGET_CFLAGS += -D'valloc(a)=aligned_alloc(getpagesize(),a)'
index 1a016ebcfb416fbbf487db65edf20b7392148616..f342f851b5548daa4f216a4e1e18da2c293673e3 100644 (file)
@@ -7,6 +7,9 @@ config zerotier sample_config
 
        #option port '9993'
 
+       # path to the local.conf
+       #option local_conf '/etc/zerotier.conf'
+
        # Generate secret on first start
        option secret ''
 
index ba6b427fa75cf537a1451c7a3038928dedcfc4d8..dacb47c09a54a0af7bd08cbdbf4fd4d69ec72b2f 100755 (executable)
@@ -14,7 +14,7 @@ section_enabled() {
 
 start_instance() {
        local cfg="$1"
-       local port secret config_path path
+       local port secret config_path local_conf path
        local args=""
 
        if ! section_enabled "$cfg"; then
@@ -25,6 +25,7 @@ start_instance() {
        config_get config_path $cfg 'config_path'
        config_get port $cfg 'port'
        config_get secret $cfg 'secret'
+       config_get local_conf $cfg 'local_conf'
 
        path=${CONFIG_PATH}_$cfg
 
@@ -71,6 +72,10 @@ start_instance() {
                rm -f $path/identity.public
        fi
 
+       if [ -f "$local_conf" ]; then
+               ln -s "$local_conf" $path/local.conf
+       fi
+
        add_join() {
                # an (empty) config file will cause ZT to join a network
                touch $path/networks.d/$1.conf