global: change all instances of USE_EGLIBC to USE_GLIBC
authorJohn Crispin <blogic@openwrt.org>
Thu, 12 Mar 2015 17:23:49 +0000 (18:23 +0100)
committerJohn Crispin <blogic@openwrt.org>
Thu, 12 Mar 2015 19:52:37 +0000 (20:52 +0100)
Signed-off-by: John Crispin <blogic@openwrt.org>
devel/diffutils/Makefile
lang/luaposix/Makefile
lang/perl/Config.in
lang/perl/Makefile
lang/perl/perlmod.mk
utils/pciutils/Makefile

index 33cdc12165dd479d499eae538507ded6b38810e5..b313dafa420e2260c9411a43d47437a3c70e9e22 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/diffutils
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=+USE_EGLIBC:librt
+  DEPENDS:=+USE_GLIBC:librt
   TITLE:=diffutils
   URL:=http://www.gnu.org/software/diffutils/
 endef
index dd4a056716d722e7e612dcc5dfbb69002e78f194..40cddc054e19df01da64866faf121dd18846454a 100644 (file)
@@ -42,7 +42,7 @@ CONFIGURE_VARS += ac_cv_path_LDOC=""
 
 TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
 
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_GLIBC),)
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
     TARGET_CFLAGS += -DNO_GETLOGIN
   endif
index 11cb5eb1126ec75fcbee79a607d5cf8452d7ef21..f4c4f8870ae4de3d84c0f08161c41e0dc1b24912 100644 (file)
@@ -3,7 +3,7 @@ menu "Configuration"
 
 config PERL_THREADS
     bool "Enable threading support"
-    default y if (mips || mipsel || i386 || i686 || x86_64 || armeb || arm) && (USE_UCLIBC || USE_EGLIBC)
+    default y if (mips || mipsel || i386 || i686 || x86_64 || armeb || arm) && (USE_UCLIBC || USE_GLIBC)
     default n
 
 config PERL_TESTS
index c3fe981f94e1bf1fee8e3ff3238a1d09b4818901..abd327f6200382093f4bf14529dbf84eefc25c1e 100644 (file)
@@ -36,7 +36,7 @@ HOST_BUILD_PARALLEL:=1
 
 # Variables used during configuration/build
 HOST_PERL_PREFIX:=$(STAGING_DIR_HOST)/usr
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_GLIBC),)
        EXTRA_LIBS:=bsd
        EXTRA_LIBDIRS:=$(STAGING_DIR)/lib
 endif
@@ -50,7 +50,7 @@ ifdef CONFIG_PERL_THREADS
        PERL_CONFIG_SUFFIX:=-mt
 
        # uclibc doesn't provide crypt_r(). Enable crypt() usage for glibc builds only
-       ifdef CONFIG_USE_EGLIBC
+       ifdef CONFIG_USE_GLIBC
                CRYPT_R_PROTO:=REENTRANT_PROTO_B_CCS
                CRYPT:=define
        else
@@ -79,7 +79,7 @@ define Package/perl
   CATEGORY:=Languages
   TITLE:=The Perl intepreter
   URL:=http://www.perl.com/
-  DEPENDS:=+USE_EGLIBC:libbsd +PERL_THREADS:libpthread
+  DEPENDS:=+USE_GLIBC:libbsd +PERL_THREADS:libpthread
 endef
 
 define Package/perl/description
index 4a4181d28523c9bc5854158099758f861b63b400..5b6ba1655233ccb11e6a99509fc816428d150e09 100644 (file)
@@ -3,7 +3,7 @@
 
 # Build environment
 HOST_PERL_PREFIX:=$(STAGING_DIR_HOST)/usr
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_GLIBC),)
        EXTRA_LIBS:=bsd
        EXTRA_LIBDIRS:=$(STAGING_DIR)/lib
 endif
index 90deb66a47e1199982d3bf7592f87e94878c0810..0d7ec33f9a395a672d54a510eb61d3fa72aaf9b0 100644 (file)
@@ -50,7 +50,7 @@ MAKE_FLAGS += \
        HOST="$(GNU_TARGET_NAME)" \
        ZLIB="yes" \
 
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_GLIBC),)
 TARGET_LDFLAGS += -lresolv
 endif