open2300: fix build on macos
authorSergey V. Lobanov <sergey@lobanov.in>
Wed, 26 Jan 2022 22:40:54 +0000 (01:40 +0300)
committerRosen Penev <rosenp@gmail.com>
Fri, 28 Jan 2022 20:08:38 +0000 (12:08 -0800)
This patch sets UNAME=Linux due to OpenWrt is always Linux but
`uname -s` return Darwin on MacOS and fails target build.

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
utils/open2300/Makefile

index fcbf5d8e0c50da12a922cace1a782ed4a23679f5..89593f5da5335ab563b21fe220a3f35ee46e9030 100644 (file)
@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=open2300
 PKG_SOURCE_DATE:=2014-03-04
 PKG_SOURCE_VERSION:=1af8ae609da66f8e1b745533c19095c9758bfb0b
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/wezm/open2300
@@ -35,6 +35,9 @@ define Package/open2300/description
   This is an utility suite used to communicate with and collect data from a WS23XX wheather station.
 endef
 
+MAKE_FLAGS += \
+       UNAME=Linux
+
 define Package/open2300/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bin2300         $(1)/usr/bin/