packages/scpa5xx-view: use lowercase config option, use new service functions
authorNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:16:23 +0000 (22:16 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:16:23 +0000 (22:16 +0000)
SVN-Revision: 29078

multimedia/spca5xx-view/Makefile
multimedia/spca5xx-view/files/servfox.config
multimedia/spca5xx-view/files/servfox.init

index 336d4ae9386081cb55b9896ccebf8fe3af4ce80e..e36b97863903465cfe0d33a384a58e1a1a7f76d4 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=spca5xx-view
 PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=spca5xx-view.tar.bz2
 PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt
index 3138bba88bd4c6a137714235bc3acb160fc869d1..34f4f7fc4b6b089fadf79b1d3041ae05708580a9 100644 (file)
@@ -1,4 +1,4 @@
 config servfox
-       option Device       '/dev/video0'
-       option Port         '7070'
-       option Resolution   '640x480'
+       option device       '/dev/video0'
+       option port         '7070'
+       option resolution   '640x480'
index 072e595b3f6de701e55d62cc413449f4e693dc31..22a4aa25d68f2e604a204b5840a9d0a3494d85ed 100644 (file)
@@ -1,31 +1,25 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=90
 
-config_cb() {
-       local cfg="$CONFIG_SECTION"
+satrt_instance() {
+       local cfg="$1"
        local res
        local dev
        local port 
-       local cfgt
-       config_get cfgt "$cfg" TYPE
-
-       case "$cfgt" in
-               servfox)
-                       config_get res $cfg Resolution
-                       config_get dev $cfg Device
-                       config_get port $cfg Port
 
-                       SERVFOX_ARGS="${dev:+-d $dev} ${res:+-s $res} ${port:+-w $port}"
-               ;;
-       esac
+       config_get res "$cfg" 'resolution'
+       config_get dev "$cfg" 'device'
+       config_get port "$cfg" 'port'
+       service_start bin/servfox ${dev:+-d $dev} ${res:+-s $res} ${port:+-w $port}
 }
 
 start() {
-       config_load servfox 
-       /bin/servfox $SERVFOX_ARGS &
+       config_load 'servfox'
+       config_foreach start_instance 'servfox'
 }
 
 stop() {
-       killall servfox 
+       service_stop /bin/servfox
 }