tesseract: add workaround for byte-order mark in source file, backfire gcc chokes...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 6 Nov 2011 23:35:14 +0000 (23:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 6 Nov 2011 23:35:14 +0000 (23:35 +0000)
SVN-Revision: 28791

utils/tesseract/Makefile

index bd99117c694d24ffb9d6ec0d3036952eec765e4e..b174433145e5ada4e397cd0ecad1bbc91d9ae44b 100644 (file)
@@ -33,6 +33,11 @@ CONFIGURE_ARGS += \
 
 TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       $(SED) '1s/^\xEF\xBB\xBF//' $(PKG_BUILD_DIR)/ccutil/strngs.h 
+endef
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/tesseract $(1)/usr/include/