add extra wlcompat debug package, saves some bytes on the default image, okay nbd@
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 29 Jun 2005 20:59:07 +0000 (20:59 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 29 Jun 2005 20:59:07 +0000 (20:59 +0000)
SVN-Revision: 1294

openwrt/target/linux/package/wlcompat/Config.in
openwrt/target/linux/package/wlcompat/Makefile
openwrt/target/linux/package/wlcompat/ipkg/kmod-wlcompat-debug.control [new file with mode: 0644]

index 926cf4b3c42aabc070a6b2d7c79cda41a92d7727..a3420427249d337b0c06db1d86c65b1cfce257cf 100644 (file)
@@ -5,3 +5,11 @@ config BR2_PACKAGE_KMOD_WLCOMPAT
        help
          A wrapper module, that provides Wireless Extension support for the
          proprietary Broadcom wl module.
+
+config BR2_PACKAGE_KMOD_WLCOMPAT_DEBUG
+       tristate "kmod-wlcompat-debug"
+       default y
+       depends BR2_PACKAGE_KMOD_BRCM_WL
+       help
+         A wrapper module, that provides Wireless Extension support for the
+         proprietary Broadcom wl module. (debug version)
index 706948e8ea798e700337cf1dd390322e4a7a7dd0..419b4d2f5eae57aef938dae102028a91a3f1d980 100644 (file)
@@ -32,9 +32,15 @@ $(PKG_BUILD_DIR)/wlcompat.o: $(PKG_BUILD_DIR)/.prepared
 $(PKG_BUILD_DIR)/wlcompat-debug.o: $(PKG_BUILD_DIR)/.prepared
        $(TARGET_CC) -DDEBUG $(WLCOMPAT_FLAGS) -o $@ wlcompat.c
 
-$(IPKG_KMOD_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
+$(IPKG_KMOD_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o
        mkdir -p $(IDIR_KMOD_WLCOMPAT)/etc/modules.d
        echo "wlcompat" > $(IDIR_KMOD_WLCOMPAT)/etc/modules.d/10-wlcompat
        mkdir -p $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)
-       cp $(PKG_BUILD_DIR)/*.o $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)/
+       cp $(PKG_BUILD_DIR)/wlcompat.o $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)/
        $(IPKG_BUILD) $(IDIR_KMOD_WLCOMPAT) $(PACKAGE_DIR)
+
+$(IPKG_KMOD_WLCOMPAT_DEBUG): $(PKG_BUILD_DIR)/wlcompat-debug.o
+       mkdir -p $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)
+       cp $(PKG_BUILD_DIR)/wlcompat-debug.o $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)/
+       $(IPKG_BUILD) $(IDIR_KMOD_WLCOMPAT_DEBUG) $(PACKAGE_DIR)
+
diff --git a/openwrt/target/linux/package/wlcompat/ipkg/kmod-wlcompat-debug.control b/openwrt/target/linux/package/wlcompat/ipkg/kmod-wlcompat-debug.control
new file mode 100644 (file)
index 0000000..1c8f1ea
--- /dev/null
@@ -0,0 +1,7 @@
+Package: kmod-wlcompat-debug
+Priority: optional
+Section: sys
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: kmod-brcm-wl
+Description: Compatibility module for using the Wireless Extension with broadcom's wl (debug)