lvm2: fix CE in mac 13087/head
authorLiangbin Lian <jjm2473@gmail.com>
Fri, 14 Aug 2020 06:19:12 +0000 (14:19 +0800)
committerLiangbin Lian <jjm2473@gmail.com>
Fri, 14 Aug 2020 06:19:12 +0000 (14:19 +0800)
command-count.h generated by makefile was wrong
when using default shell in mac,
set shell to bash to fix it.

Signed-off-by: Liangbin Lian <jjm2473@gmail.com>
utils/lvm2/Makefile

index 2ecbab7908cf818ec9953cb039f37f3d6e049c33..23824c37f6efb4e9d5ba0ffdb892129034f99f30 100644 (file)
@@ -61,10 +61,15 @@ CONFIGURE_ARGS += \
        --with-default-run-dir=/var/run/lvm \
        --with-default-locking-dir=/var/lock/lvm
 
+ifneq ($(shell /bin/sh -c "echo -n 'X'"),X)
+MAKE_SHELL = SHELL=/bin/bash
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(FPIC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               $(MAKE_SHELL) \
                install
 endef