prosody: fix use of randomseed (prosody issue #439) 717/head
authorW. Michael Petullo <mike@flyn.org>
Fri, 2 Jan 2015 19:22:54 +0000 (14:22 -0500)
committerW. Michael Petullo <mike@flyn.org>
Fri, 2 Jan 2015 19:22:54 +0000 (14:22 -0500)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
net/prosody/Makefile
net/prosody/patches/010-fix-randomseed.patch [new file with mode: 0644]

index af437bbe5c2a0a5adc696dd958aa832b0a1a3e62..a829ce8c20a4b2a2977e5dc24a792867c94dc225 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=prosody
 PKG_VERSION:=0.9.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://prosody.im/downloads/source
diff --git a/net/prosody/patches/010-fix-randomseed.patch b/net/prosody/patches/010-fix-randomseed.patch
new file mode 100644 (file)
index 0000000..05bdffa
--- /dev/null
@@ -0,0 +1,12 @@
+diff -u --recursive prosody-0.9.7-vanilla/net/dns.lua prosody-0.9.7/net/dns.lua
+--- prosody-0.9.7-vanilla/net/dns.lua  2015-01-02 00:26:19.981433830 -0500
++++ prosody-0.9.7/net/dns.lua  2015-01-02 00:33:10.467077715 -0500
+@@ -225,7 +225,7 @@
+ function dns.random(...)    -- - - - - - - - - - - - - - - - - - -  dns.random
+-      math.randomseed(math.floor(10000*socket.gettime()) % 0x100000000);
++      math.randomseed(math.floor(10000*socket.gettime()) % 0x80000000);
+       dns.random = math.random;
+       return dns.random(...);
+ end