Merge pull request #22072 from commodo/python-updates1
authorAlexandru Ardelean <alex@shruggie.ro>
Sun, 10 Sep 2023 17:02:01 +0000 (20:02 +0300)
committerGitHub <noreply@github.com>
Sun, 10 Sep 2023 17:02:01 +0000 (20:02 +0300)
chardet,numpy,django: bump versions

32 files changed:
admin/sudo/Makefile
lang/python/python-appdirs/Makefile
lang/python/python-build/Makefile
lang/python/python-click-log/Makefile
lang/python/python-contextlib2/Makefile
lang/python/python-crcmod/Makefile
lang/python/python-cryptodome/Makefile
lang/python/python-cryptodome/patches/001-fix-libgmp-loading.patch
lang/python/python-cryptodome/patches/002-omit-tests.patch
lang/python/python-cryptodomex/Makefile
lang/python/python-cryptodomex/patches/001-fix-libgmp-loading.patch
lang/python/python-cryptodomex/patches/002-omit-tests.patch
lang/python/python-decorator/Makefile
lang/python/python-influxdb/Makefile
lang/python/python-intelhex/Makefile
lang/python/python-jsonpath-ng/Makefile
lang/python/python-pyserial/Makefile
lang/python/python-ruamel-yaml/Makefile [new file with mode: 0644]
lang/python/python-schema/Makefile
lang/python/python-xmltodict/Makefile [new file with mode: 0644]
lang/python/python-yaml/Makefile
lang/python/python-zeroconf/Makefile
lang/python/python-zipp/Makefile
lang/python/ruamel-yaml/Makefile [deleted file]
lang/python/xmltodict/Makefile [deleted file]
utils/bigclown/bigclown-control-tool/Makefile
utils/bigclown/bigclown-firmware-tool/Makefile
utils/bigclown/bigclown-gateway/Makefile
utils/bigclown/bigclown-mqtt2influxdb/Makefile
utils/dbus/Makefile
utils/dbus/patches/010-cmake-paths.patch [deleted file]
utils/dbus/patches/020-cmake-fix-tmp-session-search.patch [deleted file]

index b6a84a3786d68fff2118d8f18ef9e96c219ad12a..4057929732ea3117fa0929c487d9aa4846ba777b 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sudo
-PKG_VERSION:=1.9.14p1
+PKG_VERSION:=1.9.14p3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.sudo.ws/dist
-PKG_HASH:=e91bf5ef2e09d857ee901c3465cf7ddb37e43c763b65d19fa0862d1dec128faf
+PKG_HASH:=a08318b1c4bc8582c004d4cd9ae2903abc549e7e46ba815e41fe81d1c0782b62
 
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
 
index cf8d67018fc2528d3e8315e017a4d323fbb0aa30..a17bb51ac77c7f2b2de62fc49a8ee5cbd4bcffa2 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=python-appdirs
 PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 
 PYPI_NAME:=appdirs
 PKG_HASH:=7d5d0167b2b1ba821647616af46a749d1c653740dd0d2415100fe26e27afdf41
index e93025a6319c9b58d65d0e1f7376101e7312a0cc..39a35565a6c0bbf57ca22b70124b9697f918c907 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-build
-PKG_VERSION:=0.10.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
 
 PYPI_NAME:=build
-PKG_HASH:=d5b71264afdb5951d6704482aac78de887c80691c52b88a9ad195983ca2c9269
+PKG_HASH:=49a60f212df4d9925727c2118e1cbe3abf30b393eff7d0e7287d2170eb36844d
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
index 01f6c0e820f5e28e446a52b7570eaeaa3d5f48ba..4ad7c125f6c2b6ac87d33d5e03f70fba456a4e43 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=python-click-log
 PKG_VERSION:=0.4.0
 PKG_RELEASE:=1
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 
 PYPI_NAME:=click-log
 PKG_HASH:=3970f8570ac54491237bcdb3d8ab5e3eef6c057df29f8c3d1151a51a9c23b975
index dcbed11c2031dce51c9ba024564339147eac84e5..499ef00e83d003b94be1516ed38136ac6982dd04 100644 (file)
@@ -11,7 +11,7 @@ PKG_RELEASE:=1
 PYPI_NAME:=contextlib2
 PKG_HASH:=ab1e2bfe1d01d968e1b7e8d9023bc51ef3509bba217bb730cee3827e1ee82869
 
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 PKG_LICENSE:=PSF-2.0 Apache-2.0
 PKG_LICENSE_FILES:=LICENSE.txt
 
index de59e612d1bb510dbe98b7c08b6f61c00daf34e6..6d4ded9cf49674f7a9512372850d0e5a178de35b 100644 (file)
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/package.mk
 include ../python3-package.mk
 
 define Package/python3-crcmod
-  SECTION:=lang-python
+  SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
   TITLE:=python3-crcmod
index 0f256628eb1b0da8837724db08d04ccfda7308e0..3ce76c2eb6d50e439149f89ce4162f359ad5150f 100644 (file)
@@ -5,13 +5,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-cryptodome
-PKG_VERSION:=3.9.7
-PKG_RELEASE:=4
+PKG_VERSION:=3.18.0
+PKG_RELEASE:=1
 
 PYPI_NAME:=pycryptodome
-PKG_HASH:=f1add21b6d179179b3c177c33d18a2186a09cc0d3af41ff5ed3f377360b869f2
+PKG_HASH:=c9adee653fc882d98956e33ca2c1fb582e23a8af7ac82fee75bd6113c55a0413
 
-PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE:=Public-Domain BSD-2-Clause
 PKG_LICENSE_FILES:=LICENSE.rst
 PKG_MAINTAINER:=Richard Yu <yurichard3839@gmail.com>
 PKG_CPE_ID:=cpe:/a:pycryptodome:pycryptodome
@@ -24,12 +24,12 @@ PYTHON3_PKG_BUILD_VARS:= \
   CONFIG_BIG_ENDIAN="$(CONFIG_BIG_ENDIAN)"
 
 define Package/python3-cryptodome
-  SECTION:=lang-python
+  SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
-  TITLE:=A self-contained cryptographic library for Python
+  TITLE:=Self-contained cryptographic library
   URL:=https://www.pycryptodome.org/
-  DEPENDS:=+libgmp +python3
+  DEPENDS:=+libgmp +python3-light +python3-cffi
   PROVIDES:=python3-crypto
 endef
 
index d7591100c948a0732fd8a30ddcce4178f1f7c45e..a0d9674b3b04660606f46669857271389d6f8227 100644 (file)
@@ -1,8 +1,8 @@
 --- a/lib/Crypto/Math/_IntegerGMP.py
 +++ b/lib/Crypto/Math/_IntegerGMP.py
-@@ -92,7 +92,7 @@ gmp_defs = """typedef unsigned long UNIX
-         int __gmpz_divisible_ui_p (const mpz_t n, UNIX_ULONG d);
-         """
+@@ -97,7 +97,7 @@ gmp_defs = """typedef unsigned long UNIX
+ if sys.platform == "win32":
+     raise ImportError("Not using GMP on Windows")
  
 -lib = load_lib("gmp", gmp_defs)
 +lib = load_lib("libgmp.so.10", gmp_defs)
index 37a922c54dba7a043900bab83f9f53818d5fe100..43e2cc3d883dc18405e3c8c1b8834e368361ace7 100644 (file)
@@ -1,7 +1,7 @@
 --- a/setup.py
 +++ b/setup.py
-@@ -301,6 +301,9 @@ package_data = {
-     ],
+@@ -276,6 +276,9 @@ package_data = {
+     "Crypto.Util" : [ "*.pyi" ],
  }
  
 +packages = [i for i in packages if not i.startswith('Crypto.SelfTest')]
index 9847db5832521d69922eb2556ed6dd2eeece0a35..a9265950c4341b74b9e6944dadc5993f67782ead 100644 (file)
@@ -5,13 +5,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-cryptodomex
-PKG_VERSION:=3.10.1
-PKG_RELEASE:=2
+PKG_VERSION:=3.18.0
+PKG_RELEASE:=1
 
 PYPI_NAME:=pycryptodomex
-PKG_HASH:=541cd3e3e252fb19a7b48f420b798b53483302b7fe4d9954c947605d0a263d62
+PKG_HASH:=3e3ecb5fe979e7c1bb0027e518340acf7ee60415d79295e5251d13c68dde576e
 
-PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE:=Public-Domain BSD-2-Clause
 PKG_LICENSE_FILES:=LICENSE.rst
 PKG_MAINTAINER:=Richard Yu <yurichard3839@gmail.com>
 
@@ -23,12 +23,12 @@ PYTHON3_PKG_BUILD_VARS:= \
   CONFIG_BIG_ENDIAN="$(CONFIG_BIG_ENDIAN)"
 
 define Package/python3-cryptodomex
-  SECTION:=lang-python
+  SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
-  TITLE:=A self-contained cryptographic library for Python
+  TITLE:=Self-contained cryptographic library
   URL:=https://www.pycryptodome.org/
-  DEPENDS:=+libgmp +python3
+  DEPENDS:=+libgmp +python3-light +python3-cffi
 endef
 
 define Package/python3-cryptodomex/description
index da4ca52b466052a45e6938b0cb0a677f9dd64d0f..305ef69645935d03ca5022fc08025903bb35bf52 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/Cryptodome/Math/_IntegerGMP.py
 +++ b/lib/Cryptodome/Math/_IntegerGMP.py
-@@ -95,7 +95,7 @@ gmp_defs = """typedef unsigned long UNIX
+@@ -97,7 +97,7 @@ gmp_defs = """typedef unsigned long UNIX
  if sys.platform == "win32":
      raise ImportError("Not using GMP on Windows")
  
index 457e785ca6814872de843fccd1c7fd6abe800a03..43e2cc3d883dc18405e3c8c1b8834e368361ace7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/setup.py
 +++ b/setup.py
-@@ -275,6 +275,9 @@ package_data = {
+@@ -276,6 +276,9 @@ package_data = {
      "Crypto.Util" : [ "*.pyi" ],
  }
  
index 27ae1a8c2613d3d11227bf834960cd5b80bdc713..de2a49a189e71d7034f0e0c31626f50629cf3734 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=python-decorator
 PKG_VERSION:=4.4.2
 PKG_RELEASE:=1
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 PKG_CPE_ID:=cpe:/a:python:decorator
 
 PYPI_NAME:=decorator
index 881ce77dee3c06c76374de7f3ce9334748df77b0..a71d9fd4760028ce06c79b97d1c2dd4746471b3d 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=python-influxdb
 PKG_VERSION:=5.3.1
 PKG_RELEASE:=1
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 
 PYPI_NAME:=influxdb
 PKG_HASH:=46f85e7b04ee4b3dee894672be6a295c94709003a7ddea8820deec2ac4d8b27a
index 19fc2ac06948102f726343b605cfe6b4752d2160..40c38426c0ebc54f7676195367820e4d0b1f60ae 100644 (file)
@@ -11,7 +11,7 @@ PKG_RELEASE:=1
 PYPI_NAME:=intelhex
 PKG_HASH:=892b7361a719f4945237da8ccf754e9513db32f5628852785aea108dcd250093
 
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE.txt
 
index 8214743e581cdd17d258480a2d071489846ad00a..e3b0669bcf959ca27143a14e92dfd66205d70f7f 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=python-jsonpath-ng
 PKG_VERSION:=1.5.3
 PKG_RELEASE:=1
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 
 PYPI_NAME:=jsonpath-ng
 PKG_HASH:=a273b182a82c1256daab86a313b937059261b5c5f8c4fa3fc38b882b344dd567
index e74cc880e47daf6f05f5b533371123c7ad508499..e6c6b401ee05819746388c638bff05aad8c20144 100644 (file)
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-pyserial
-PKG_VERSION:=3.4
-PKG_RELEASE:=2
+PKG_VERSION:=3.5
+PKG_RELEASE:=1
 
 PYPI_NAME:=pyserial
-PKG_HASH:=6e2d401fdee0eab996cf734e67773a0143b932772ca8b42451440cfed942c627
+PKG_HASH:=3c77e014170dfffbd816e6ffc205e9842efb10be9f58ec16d3e8675b4925cddb
 
-PKG_LICENSE:=BSD
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE.txt
 PKG_MAINTAINER:=Micke Prag <micke.prag@telldus.se>
 
 include ../pypi.mk
@@ -22,19 +23,19 @@ include $(INCLUDE_DIR)/package.mk
 include ../python3-package.mk
 
 define Package/python3-pyserial
-  SECTION:=lang-python
+  SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
-  TITLE:=python3-pyserial
+  TITLE:=Serial Port Extension
   URL:=https://github.com/pyserial/pyserial
-  DEPENDS:=+python3-light
+  DEPENDS:=+python3-light +python3-logging +python3-urllib
 endef
 
 define Package/python3-pyserial/description
-This module encapsulates the access for the serial port. It provides backends
-for Python running on Windows, OSX, Linux, BSD (possibly any POSIX compliant
-system) and IronPython. The module named "serial" automatically selects the
-appropriate backend.
+This module encapsulates the access for the serial port. It provides
+backends for Python running on Windows, OSX, Linux, BSD (possibly any
+POSIX compliant system) and IronPython. The module named "serial"
+automatically selects the appropriate backend.
 endef
 
 $(eval $(call Py3Package,python3-pyserial))
diff --git a/lang/python/python-ruamel-yaml/Makefile b/lang/python/python-ruamel-yaml/Makefile
new file mode 100644 (file)
index 0000000..a63b164
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-ruamel-yaml
+PKG_VERSION:=0.17.32
+PKG_RELEASE:=1
+
+PYPI_NAME:=ruamel.yaml
+PKG_HASH:=ec939063761914e14542972a5cba6d33c23b0859ab6342f61cf070cfc600efc2
+
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-ruamel-yaml
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=YAML 1.2 loader/dumper
+  URL:=https://sourceforge.net/p/ruamel-yaml/code/ci/default/tree
+  DEPENDS:= \
+      +python3-light
+endef
+
+define Package/python3-ruamel-yaml/description
+ruamel-yaml is a YAML parser/emitter that supports roundtrip
+preservation of comments, seq/map flow style, and map key order
+endef
+
+$(eval $(call Py3Package,python3-ruamel-yaml))
+$(eval $(call BuildPackage,python3-ruamel-yaml))
+$(eval $(call BuildPackage,python3-ruamel-yaml-src))
index fd1bb58600618780c029500225a4c23bc11da522..537a32fbc132ace03620213dc23c6f10dd99f39b 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=python-schema
 PKG_VERSION:=0.7.5
 PKG_RELEASE:=1
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 
 PYPI_NAME:=schema
 PKG_HASH:=f06717112c61895cabc4707752b88716e8420a8819d71404501e114f91043197
diff --git a/lang/python/python-xmltodict/Makefile b/lang/python/python-xmltodict/Makefile
new file mode 100644 (file)
index 0000000..87b841f
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-xmltodict
+PKG_VERSION:=0.13.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=xmltodict
+PKG_HASH:=341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56
+
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-xmltodict
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Work with XML like JSON
+  URL:=https://github.com/martinblech/xmltodict
+  DEPENDS:=+python3-light +python3-xml
+endef
+
+define Package/python3-xmltodict/description
+xmltodict is a Python module that makes working with XML feel like you
+are working with JSON.
+endef
+
+$(eval $(call Py3Package,python3-xmltodict))
+$(eval $(call BuildPackage,python3-xmltodict))
+$(eval $(call BuildPackage,python3-xmltodict-src))
index 26326d660c5bb9eb62b83c17edf7272fa30a95ac..c7eafc98c8b5018e46ec7fd7e415d1e23a7ed1c1 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-yaml
-PKG_VERSION:=6.0
-PKG_RELEASE:=4
+PKG_VERSION:=6.0.1
+PKG_RELEASE:=1
 
 PYPI_NAME:=PyYAML
-PKG_HASH:=68fb519c14306fec9720a2a5b45bc9f0c8d1b9c72adf45c37baedfcd949c35a2
+PKG_HASH:=bfdf460b1736c775f2ba9f6a92bca30bc2095067b8a9d77876d1fad6cc3b4a43
 
 PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
 PKG_LICENSE:=MIT
@@ -29,7 +29,7 @@ define Package/python3-yaml
   SECTION:=lang
   CATEGORY:=Languages
   SUBMENU:=Python
-  TITLE:=YAML parser and emitter for Python
+  TITLE:=YAML parser and emitter
   URL:=https://github.com/yaml/pyyaml
   DEPENDS:=+libyaml +python3-light
 endef
index 9b3e220c03829fa4391c101454652894f4f3ba73..eaa7334c4751682bdddcdcaae4087dc4658faa82 100644 (file)
@@ -8,16 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-zeroconf
-PKG_VERSION:=0.38.1
+PKG_VERSION:=0.97.0
 PKG_RELEASE:=1
 
 PYPI_NAME:=zeroconf
-PKG_HASH:=10c501b25d8881b656e56c34674d98fe6bc752240a572e74f918bc849c93ba9c
+PKG_HASH:=9a06cd21182250100df6c4f4e9de2a47a0ea927c7d5a0446035bb3dfcc17a647
 
 PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
-PKG_LICENSE:=Apache-2.0
+PKG_LICENSE:=LGPL-2.1-or-later
 PKG_LICENSE_FILES:=COPYING
 
+PKG_BUILD_DEPENDS:=python-cython/host python-poetry-core/host
+
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
 include ../python3-package.mk
@@ -27,9 +29,10 @@ define Package/python3-zeroconf
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Multicast DNS Service Discovery Library
-  URL:=https://github.com/jstasiak/python-zeroconf
+  URL:=https://github.com/python-zeroconf/python-zeroconf
   DEPENDS:= \
          +python3-light \
+         +python3-asyncio \
          +python3-logging \
          +python3-ifaddr
 endef
index 3d48b31c31c52f71fa6ae9a887b8309a37d6423a..77a6d0d9cb7fa39a33e9a3992d174e7081936b7e 100644 (file)
@@ -1,11 +1,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-zipp
-PKG_VERSION:=3.4.1
-PKG_RELEASE:=2
+PKG_VERSION:=3.16.2
+PKG_RELEASE:=1
 
 PYPI_NAME:=zipp
-PKG_HASH:=3607921face881ba3e026887d8150cca609d517579abe052ac81fc5aeffdbd76
+PKG_HASH:=ebc15946aa78bd63458992fc81ec3b6f7b1e92d51c35e6de1c3804e73b799147
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
 PKG_LICENSE:=MIT
@@ -23,7 +23,7 @@ define Package/python3-zipp
   SUBMENU:=Python
   TITLE:=Zipfile object wrapper
   URL:=https://github.com/jaraco/zipp
-  DEPENDS:=+python3-light
+  DEPENDS:=+python3-light +python3-urllib
 endef
 
 define Package/python3-zipp/description
diff --git a/lang/python/ruamel-yaml/Makefile b/lang/python/ruamel-yaml/Makefile
deleted file mode 100644 (file)
index fd8f17a..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ruamel-yaml
-PKG_VERSION:=0.17.17
-PKG_RELEASE:=1
-
-PYPI_NAME:=ruamel.yaml
-PKG_HASH:=9751de4cbb57d4bfbf8fc394e125ed4a2f170fbff3dc3d78abf50be85924f8be
-
-PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-define Package/python3-ruamel-yaml
-  SECTION:=lang
-  CATEGORY:=Languages
-  SUBMENU:=Python
-  TITLE:=YAML 1.2 loader/dumper package for Python
-  URL:=https://bitbucket.org/ruamel/yaml
-  DEPENDS:= \
-      +python3-light
-endef
-
-define Package/python3-ruamel-yaml/description
-ruamel-yaml is a YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order
-endef
-
-$(eval $(call Py3Package,python3-ruamel-yaml))
-$(eval $(call BuildPackage,python3-ruamel-yaml))
-$(eval $(call BuildPackage,python3-ruamel-yaml-src))
diff --git a/lang/python/xmltodict/Makefile b/lang/python/xmltodict/Makefile
deleted file mode 100644 (file)
index 44cf4cd..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-xmltodict
-PKG_VERSION:=0.12.0
-PKG_RELEASE:=2
-
-PYPI_NAME:=xmltodict
-PKG_HASH:=50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21
-
-PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
-
-include ../pypi.mk
-include $(INCLUDE_DIR)/package.mk
-include ../python3-package.mk
-
-define Package/python3-xmltodict
-  SECTION:=lang
-  CATEGORY:=Languages
-  SUBMENU:=Python
-  TITLE:=Work with XML like JSON
-  URL:=https://github.com/martinblech/xmltodict
-  DEPENDS:= \
-       +python3-light \
-       +python3-xml \
-       +python3-urllib
-endef
-
-define Package/python3-xmltodict/description
-  xmltodict is a Python module that makes working with XML feel like you are working with JSON.
-endef
-
-$(eval $(call Py3Package,python3-xmltodict))
-$(eval $(call BuildPackage,python3-xmltodict))
-$(eval $(call BuildPackage,python3-xmltodict-src))
index 84958d4a87d36cb08115bb5345559dab38d8647f..4aaa6febb15633099813bc08cbdcf098842f837d 100644 (file)
@@ -11,7 +11,7 @@ PKG_RELEASE:=3
 PYPI_NAME:=bch
 PKG_HASH:=4cd73b92757fce7275a4744baed411c867af2e671c521b90d6690b2320851d58
 
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 
index 6aa5fff8861cb336606c4c15e4acb99518755cbd..7c15901a887515efc83cb012da41ac00858fe37d 100644 (file)
@@ -11,7 +11,7 @@ PKG_RELEASE:=1
 PYPI_NAME:=bcf
 PKG_HASH:=8ad897586d02433d01a58b4978516621bea388cd230640eb0b8f8f9e40f10e6c
 
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 
index 5984162f312afe7fdf2b327982f634540c4b4896..6adc7c414277ab1cec599acad0dbf3116f788460 100644 (file)
@@ -11,7 +11,7 @@ PKG_RELEASE:=3
 PYPI_NAME:=bcg
 PKG_HASH:=ce7f27f372551c0beb3f8929af2d779417d9dcd0feaa2fa2dc49e87b1416c536
 
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 
index a8097e2cb0d7bd6026f442edf554feface150ea1..89b5dca6549994d568c73d788ec261b39e8eccb2 100644 (file)
@@ -11,7 +11,7 @@ PKG_RELEASE:=1
 PYPI_NAME:=mqtt2influxdb
 PKG_HASH:=9fd98d2239c0b9a2482db8e55e3e5a310c5b644aa7d42c57d35ed775adb0101a
 
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com> 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 
index e7db64debffd5f1d51b92899e2790fa1519e8412..727a10a4d32f417f00e56a209c29cff09ce63e35 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dbus
-PKG_VERSION:=1.13.18
-PKG_RELEASE:=12
+PKG_VERSION:=1.14.10
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://dbus.freedesktop.org/releases/dbus
-PKG_HASH:=8078f5c25e34ab907ce06905d969dc8ef0ccbec367e1e1707c7ecf8460f4254e
+PKG_HASH:=ba1f21d2bd9d339da2d4aa8780c09df32fea87998b73da24f49ab9df1e36a50f
 
-PKG_MAINTAINER:=
+PKG_MAINTAINER:=Robert Marko <robimarko@gmail.com>
 PKG_LICENSE:=AFL-2.1
 PKG_CPE_ID:=cpe:/a:freedesktop:dbus
 
diff --git a/utils/dbus/patches/010-cmake-paths.patch b/utils/dbus/patches/010-cmake-paths.patch
deleted file mode 100644 (file)
index 36431eb..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -510,11 +510,11 @@ if(WIN32)
- else(WIN32)
-     set(DBUS_SESSION_BUS_LISTEN_ADDRESS "unix:tmpdir=${DBUS_SESSION_SOCKET_DIR}" CACHE STRING "session bus default listening address")
-     set(DBUS_SESSION_BUS_CONNECT_ADDRESS "autolaunch:" CACHE STRING "session bus fallback address for clients")
--    set(sysconfdir "")
-+    set(sysconfdir "/usr/share")
-     set(configdir ${sysconfdir}/dbus-1 )
-     set(DBUS_SYSTEM_CONFIG_FILE  ${configdir}/system.conf)
-     set(DBUS_SESSION_CONFIG_FILE ${configdir}/session.conf)
--    set(DBUS_USER "messagebus")
-+    set(DBUS_USER "root")
-     set(DBUS_TEST_USER "nobody")
-   # For best security, assume that all non-Windows platforms can do
-   # credentials-passing.
diff --git a/utils/dbus/patches/020-cmake-fix-tmp-session-search.patch b/utils/dbus/patches/020-cmake-fix-tmp-session-search.patch
deleted file mode 100644 (file)
index 2847b62..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -471,14 +471,16 @@ endif()
- #### Find socket directories
- if(UNIX)
--    if(NOT $ENV{TMPDIR} STREQUAL "")
--        set(DBUS_SESSION_SOCKET_DIR $ENV{TMPDIR})
--    elseif(NOT $ENV{TEMP} STREQUAL "")
--        set(DBUS_SESSION_SOCKET_DIR $ENV{TEMP})
--    elseif(NOT $ENV{TMP} STREQUAL "")
--        set(DBUS_SESSION_SOCKET_DIR $ENV{TMP})
--    else()
--        set(DBUS_SESSION_SOCKET_DIR /tmp)
-+    if(NOT DEFINED DBUS_SESSION_SOCKET_DIR)
-+        if(NOT $ENV{TMPDIR} STREQUAL "")
-+            set(DBUS_SESSION_SOCKET_DIR $ENV{TMPDIR})
-+        elseif(NOT $ENV{TEMP} STREQUAL "")
-+            set(DBUS_SESSION_SOCKET_DIR $ENV{TEMP})
-+        elseif(NOT $ENV{TMP} STREQUAL "")
-+            set(DBUS_SESSION_SOCKET_DIR $ENV{TMP})
-+        else()
-+            set(DBUS_SESSION_SOCKET_DIR /tmp)
-+        endif()
-     endif()
- endif()