ddns-scripts: Fix for domains with dash 15664/head
authorWenli Looi <wlooi@ucalgary.ca>
Wed, 19 May 2021 18:42:25 +0000 (11:42 -0700)
committerlooi <looi@users.noreply.github.com>
Wed, 19 May 2021 18:43:07 +0000 (11:43 -0700)
Signed-off-by: Wenli Looi <wlooi@ucalgary.ca>
net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh

index 3b54e604fca87e399cb0597907c89c970e3f1d34..047eab9c8353825cfd1544f1fbcdaf0a91819b4b 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.8.2
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_LICENSE:=GPL-2.0
 
index b5dac0ee287de8b338055e74c034e0d7b2608632..2a677785ee1ffc0fca857fe6ec5c0e5338654b32 100644 (file)
@@ -70,11 +70,11 @@ IPV6_REGEX="\(\([0-9A-Fa-f]\{1,4\}:\)\{1,\}\)\(\([0-9A-Fa-f]\{1,4\}\)\{0,1\}\)\(
 # characters that are dangerous to pass to a shell command line
 SHELL_ESCAPE="[\"\'\`\$\!();><{}?|\[\]\*\\\\]"
 
-# dns character set
+# dns character set. "-" must be the last character
 DNS_CHARSET="[@a-zA-Z0-9._-]"
 
-# domains can have * for wildcard
-DNS_CHARSET_DOMAIN="[@a-zA-Z0-9._-*]"
+# domains can have * for wildcard. "-" must be the last character
+DNS_CHARSET_DOMAIN="[@a-zA-Z0-9._*-]"
 
 # detect if called by ddns-lucihelper.sh script, disable retrys (empty variable == false)
 LUCI_HELPER=$(printf %s "$MYPROG" | grep -i "luci")