update to postgresql 8.3 and refresh patches
authorTim Yardley <lst@openwrt.org>
Wed, 6 Feb 2008 22:38:13 +0000 (22:38 +0000)
committerTim Yardley <lst@openwrt.org>
Wed, 6 Feb 2008 22:38:13 +0000 (22:38 +0000)
SVN-Revision: 10408

libs/postgresql/Makefile
libs/postgresql/patches/200-ranlib.patch
libs/postgresql/patches/750-configure-honor-cppflags.patch [deleted file]
libs/postgresql/patches/800-busybox-default-pager.patch
libs/postgresql/patches/850-uclibc_no_cbrt.patch

index 8f3517ccc56d9119bef5da611f8ada973fecaade..b59d9f95c0b7f03ca0da2cc6758de9e89ce69102 100644 (file)
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=8.2.6
-PKG_RELEASE:=2
+PKG_VERSION:=8.3.0
+PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -20,7 +20,7 @@ PKG_SOURCE_URL:=\
        http://ftp9.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION) \
        http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=17b9049b4fcad42ee95410833c1db228
+PKG_MD5SUM:=53d6816eac7442f9bc8103439ebee22e
 
 PKG_BUILD_DEPENDS:=libnotimpl
 
index ef7d08a8fee503e366b81351fbffddae1c8cdf97..a33eb74be0d1ff8f3e6bd97983224584abc501f9 100644 (file)
@@ -1,12 +1,12 @@
-Index: postgresql-8.2.5/src/port/Makefile
+Index: postgresql-8.3.0/src/port/Makefile
 ===================================================================
---- postgresql-8.2.5.orig/src/port/Makefile    2007-09-20 10:18:17.000000000 -0500
-+++ postgresql-8.2.5/src/port/Makefile 2007-09-20 10:18:17.000000000 -0500
-@@ -43,6 +43,7 @@
+--- postgresql-8.3.0.orig/src/port/Makefile    2008-02-06 16:27:48.000000000 -0600
++++ postgresql-8.3.0/src/port/Makefile 2008-02-06 16:28:18.000000000 -0600
+@@ -49,6 +49,7 @@
  
- libpgport.a: $(LIBOBJS)
+ libpgport.a: $(OBJS)
        $(AR) $(AROPT) $@ $^
 +      $(RANLIB) libpgport.a
  
+ # thread.o needs PTHREAD_CFLAGS (but thread_srv.o does not)
  thread.o: thread.c
-       $(CC) $(CFLAGS) $(CPPFLAGS) $(PTHREAD_CFLAGS) -c $<
diff --git a/libs/postgresql/patches/750-configure-honor-cppflags.patch b/libs/postgresql/patches/750-configure-honor-cppflags.patch
deleted file mode 100644 (file)
index f2d20d8..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: postgresql-8.2.5/src/template/linux
-===================================================================
---- postgresql-8.2.5.orig/src/template/linux   2007-09-20 10:18:17.000000000 -0500
-+++ postgresql-8.2.5/src/template/linux        2007-09-20 10:18:17.000000000 -0500
-@@ -1,4 +1,4 @@
- # $PostgreSQL: pgsql/src/template/linux,v 1.28 2006/03/11 04:38:41 momjian Exp $
- # Force _GNU_SOURCE on; plperl is broken with Perl 5.8.0 otherwise
--CPPFLAGS="-D_GNU_SOURCE"
-+CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
index 0960c1a57987dbff59e587c198c28ecbd1582575..0587f35037f872d16d95b55ca881e38c70adafcd 100644 (file)
@@ -1,8 +1,8 @@
-Index: postgresql-8.2.5/src/bin/psql/print.h
+Index: postgresql-8.3.0/src/bin/psql/print.h
 ===================================================================
---- postgresql-8.2.5.orig/src/bin/psql/print.h 2007-09-20 10:18:16.000000000 -0500
-+++ postgresql-8.2.5/src/bin/psql/print.h      2007-09-20 10:18:17.000000000 -0500
-@@ -88,10 +88,6 @@
+--- postgresql-8.3.0.orig/src/bin/psql/print.h 2008-01-01 13:45:56.000000000 -0600
++++ postgresql-8.3.0/src/bin/psql/print.h      2008-02-06 16:29:56.000000000 -0600
+@@ -89,10 +89,6 @@
  
  void          setDecimalLocale(void);
  
index 6d8fac8dd82322cdcc7f69cc9fc00f5eed5746b8..f60f0f22f9f518668117622eb89a7f19f06fdd2e 100644 (file)
@@ -1,8 +1,8 @@
-Index: postgresql-8.2.5/src/backend/utils/adt/float.c
+Index: postgresql-8.3.0/src/backend/utils/adt/float.c
 ===================================================================
---- postgresql-8.2.5.orig/src/backend/utils/adt/float.c        2007-09-20 10:18:16.000000000 -0500
-+++ postgresql-8.2.5/src/backend/utils/adt/float.c     2007-09-20 10:18:17.000000000 -0500
-@@ -110,7 +110,9 @@
+--- postgresql-8.3.0.orig/src/backend/utils/adt/float.c        2008-01-01 13:45:52.000000000 -0600
++++ postgresql-8.3.0/src/backend/utils/adt/float.c     2008-02-06 16:30:02.000000000 -0600
+@@ -71,7 +71,9 @@
  static int    float8_cmp_internal(float8 a, float8 b);
  
  #ifndef HAVE_CBRT
@@ -13,7 +13,7 @@ Index: postgresql-8.2.5/src/backend/utils/adt/float.c
  #endif   /* HAVE_CBRT */
  
  
-@@ -2831,7 +2833,7 @@
+@@ -2733,7 +2735,7 @@
  #ifndef HAVE_CBRT
  
  static double