kernel: modules: ext4 depends on crypto-hash on 3.6
authorJonas Gorski <jogo@openwrt.org>
Sun, 11 Nov 2012 19:42:35 +0000 (19:42 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 11 Nov 2012 19:42:35 +0000 (19:42 +0000)
SVN-Revision: 34159

package/kernel/modules/fs.mk

index 0bc0d55787b6db40c9d5f602f254cffe48e05272..bb0226b6ca7f42171c4aab36b4f5b7da11d6448f 100644 (file)
@@ -94,7 +94,7 @@ define KernelPackage/fs-ext4
        $(LINUX_DIR)/fs/jbd2/jbd2.ko \
        $(LINUX_DIR)/fs/mbcache.ko
   AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
-  $(call AddDepends/crc16)
+  $(call AddDepends/crc16, +!LINUX_3_3:kmod-crypto-hash)
 endef
 
 define KernelPackage/fs-ext4/description