Merge pull request #13467 from ja-pa/tor-update-0.4.4.5
authorRosen Penev <rosenp@gmail.com>
Thu, 1 Oct 2020 21:43:05 +0000 (14:43 -0700)
committerGitHub <noreply@github.com>
Thu, 1 Oct 2020 21:43:05 +0000 (14:43 -0700)
tor: update to version 0.4.4.5

net/tor/Makefile

index c7081f5c1f4ba514d660d3a8b6a3b7c9d26ee5b6..e3dd99df37d0d9ad98349cd5d1d6094db9fff35f 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor
-PKG_VERSION:=0.4.3.6
+PKG_VERSION:=0.4.4.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://dist.torproject.org/ \
        https://archive.torproject.org/tor-package-archive
-PKG_HASH:=6a2d0637d4e514be2ec574723a05065245cce51da78a21cec1dc831be5ccac62
+PKG_HASH:=a45ca00afe765e3baa839767c9dd6ac9a46dd01720a3a8ff4d86558c12359926
 PKG_MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de> \
                Peter Wagner <tripolar@gmx.at>
 PKG_LICENSE_FILES:=LICENSE
@@ -104,13 +104,14 @@ CONFIGURE_ARGS += \
        --disable-zstd \
        --with-tor-user=tor \
        --with-tor-group=tor \
-       --with-pic
+       --enable-pic
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
 TARGET_LDFLAGS += -Wl,--gc-sections -flto
 
 CONFIGURE_VARS += \
-       CROSS_COMPILE="yes"
+       CROSS_COMPILE="yes" \
+       ac_cv_func_mallinfo=no
 
 define Package/tor/install
        $(INSTALL_DIR) $(1)/usr/sbin