Merge pull request #2815 from commodo/python-setuptools-upgrade
authorHannu Nyman <hannu.nyman@iki.fi>
Sat, 4 Jun 2016 11:52:22 +0000 (14:52 +0300)
committerHannu Nyman <hannu.nyman@iki.fi>
Sat, 4 Jun 2016 11:52:22 +0000 (14:52 +0300)
python-setuptools: upgrade to version 22.0.5

lang/python-pip/Makefile
lang/python3-pip/Makefile
lang/python3-setuptools/Makefile
net/adblock/Makefile
net/adblock/files/README.md
net/adblock/files/adblock-helper.sh
net/adblock/files/adblock-update.sh
net/adblock/files/adblock.conf
net/adblock/files/adblock.init
utils/lrzsz/Makefile [new file with mode: 0644]
utils/lrzsz/patches/100-install_delete_fix.patch [new file with mode: 0644]

index 79efc45639e8c12253a0d1f5f7aeb99766a34ed6..3be9565160405e5fb94e01087db25a889aefdf08 100644 (file)
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-pip
-PKG_VERSION:=8.1.1
+PKG_VERSION:=8.1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=pip-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pip/
-PKG_MD5SUM:=6b86f11841e89c8241d689956ba99ed7
+PKG_SOURCE_URL:=https://pypi.python.org/packages/e7/a8/7556133689add8d1a54c0b14aeff0acb03c64707ce100ecd53934da1aa13/
+PKG_MD5SUM:=87083c0b9867963b29f7aba3613e8f4a
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/pip-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/python-pip-$(PKG_VERSION)
+PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 PKG_USE_MIPS16:=0
 
 include $(INCLUDE_DIR)/package.mk
index d5a50302d9722a9d8140f0a57eda134c577dfc7a..b7680b933433a528eae9a559e4df5eb1f13dc806 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python3-pip
-PKG_VERSION:=8.1.1
+PKG_VERSION:=8.1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=pip-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pip/
-PKG_MD5SUM:=6b86f11841e89c8241d689956ba99ed7
+PKG_SOURCE_URL:=https://pypi.python.org/packages/e7/a8/7556133689add8d1a54c0b14aeff0acb03c64707ce100ecd53934da1aa13/
+PKG_MD5SUM:=87083c0b9867963b29f7aba3613e8f4a
 
 PKG_LICENSE:=MIT
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/pip-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/python3-pip-$(PKG_VERSION)
+PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 PKG_USE_MIPS16:=0
 
 include $(INCLUDE_DIR)/package.mk
index 0d6352bfa82be42dca35bc5ffb14e49c0ad756a4..f8ff0a7a07f2e41f3ed090b20f6f3ff7522be25d 100644 (file)
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python3-setuptools
-PKG_VERSION:=20.7.0
+PKG_VERSION:=22.0.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=setuptools-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/setuptools/
-PKG_MD5SUM:=5d12b39bf3e75e80fdce54e44b255615
+PKG_SOURCE_URL:=https://pypi.python.org/packages/90/7a/b64d5804b6d1aebed1892e4df1c21bcb4f8480095ba8004e48999601119d/
+PKG_MD5SUM:=869f3029dcc66a64ba39875e2a2f044a
 
 PKG_LICENSE:=PSF
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/setuptools-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/python3-setuptools-$(PKG_VERSION)
+PKG_UNPACK=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 
 include $(INCLUDE_DIR)/package.mk
 $(call include_mk, python3-package.mk)
index 4fa8fdf5183521195304336dcfe720af196e1f17..21fe36b46f57ef35ab45ac6732f2853f7c47af2f 100644 (file)
@@ -7,8 +7,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
-PKG_VERSION:=1.1.16
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.17
+PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
index 86fcb208b4d04d6b16283beea0811390ba50719d..adb3eb912e0aa1887de606d091a55129332fce8d 100644 (file)
@@ -39,7 +39,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
     * => weekly updates, approx. 12.000 entries
     * [winhelp](http://winhelp2002.mvps.org)
     * => infrequent updates, approx. 15.000 entries
-    * [winspy](https://raw.githubusercontent.com/crazy-max/WindowsSpyBlocker/master/hosts/windows10_spy.txt)
+    * [winspy](https://github.com/crazy-max/WindowsSpyBlocker)
     * => infrequent updates, approx. 120 entries
     * [yoyo](http://pgl.yoyo.org/adservers)
     * => weekly updates, approx. 2.500 entries (enabled by default)
@@ -102,8 +102,9 @@ A lot of people already use adblocker plugins within their desktop browsers, but
 * **list updates:** for a scheduled call of the adblock service add an appropriate crontab entry (see example below)
 * **new list sources:** you could add new blocklist sources on your own via uci config, all you need is a source url and an awk one-liner (see example below)
 * **AP mode:** in AP mode adblock uses automatically the local router ip as nullip address. To make sure that your LuCI interface will be still accessible, please change the local uhttpd instance to ports <> 80/443 (see example below)
+* **Restricted mode:** to disable flash writes with adblock status information to the adblock config file (used by LuCI frontend), please set 'adb\_restricted' to '1'
 * **adblock toggle:** to quickly switch adblocking 'on' or 'off', simply use _/etc/init.d/adblock toggle_
-* **outdated configuration:** to update an outdated adblock config file, please use _/etc/init.d/adblock cfgup_, make your individual changes and restart the adblock service
+* **configuration update:** to update an outdated adblock config file with the current default version, please run _/etc/init.d/adblock cfgup_, make your individual changes and start the adblock service again
 * **debugging:** for script debugging please set the 'adb\_debug' variable in the header of _/etc/init.d/adblock_ to '1'
 * **disable active dns probing in windows:** to prevent a possible yellow exclamation mark on your internet connection icon (which wrongly means connected, but no internet), please change the following registry key/value from "1" to "0" _HKLM\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing_
 
@@ -115,7 +116,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
     * adb\_nullport => port of the adblock uhttpd instance (default: '65535')
     * adb\_nullipv4 => IPv4 blackhole ip address (default: '192.0.2.1', in AP mode: local router ip)
     * adb\_nullipv6 => IPv6 blackhole ip address (default: '::ffff:c000:0201', in AP mode: local router ip)
-    * adb\_forcedns => redirect all DNS queries to local dnsmasq resolver (default: '1', enabled)
+    * adb\_forcedns => redirect all local DNS queries to the local dnsmasq resolver (default: '1', enabled)
     * adb\_fetchttl => set the timeout for list downloads (default: '5' seconds)
     * adb\_restricted => disable updates of the adblock config file (no flash writes) during runtime (default: '0', disabled)
 
index c6ebc271c899379ea976a161e50bfa343ec7ef6e..f447c99f8c6f51ca065d8e73a8d38acef8ae9000 100644 (file)
@@ -142,7 +142,7 @@ f_envload()
 
     # check running dnsmasq instance
     #
-    check="$(ps | pgrep -f "dnsmasq")"
+    check="$(pgrep -f "dnsmasq")"
     if [ -z "${check}" ]
     then
         rc=-1
@@ -389,7 +389,7 @@ f_envcheck()
 
     # check volatile adblock uhttpd instance configuration
     #
-    check="$(ps | pgrep -f "uhttpd -h /www/adblock")"
+    check="$(pgrep -f "uhttpd -h /www/adblock")"
     if [ -z "${check}" ]
     then
         if [ -n "${adb_wanif4}" ] && [ -n "${adb_wanif6}" ]
@@ -617,7 +617,7 @@ f_restore()
     then
         /etc/init.d/dnsmasq restart
         sleep 1
-        check="$(ps | pgrep -f "dnsmasq")"
+        check="$(pgrep -f "dnsmasq")"
         if [ -n "${check}" ]
         then
             rc=0
index b5dbed9e1f1b37e063065cc2a5653b53d7ea7321..6421e47c6f75eca1be094e8ed60b2840f58a2f8d 100755 (executable)
 #
 LC_ALL=C
 
-# quiet output if 'adb_debug' not set
-#
-if [ -z "${adb_debug}" ]
-then
-    exec 2>/dev/null
-fi
-
 # set pid & logger
 #
 adb_pid="${$}"
@@ -35,8 +28,8 @@ fi
 # get current directory and set script/config version
 #
 adb_scriptdir="${0%/*}"
-adb_scriptver="1.1.16"
-adb_mincfgver="2.0"
+adb_scriptver="1.1.17"
+adb_mincfgver="2.1"
 
 # source in adblock function library
 #
@@ -301,7 +294,7 @@ then
     "${adb_uci}" -q set "adblock.global.adb_dnstoggle=on"
     /etc/init.d/dnsmasq restart
     sleep 1
-    check="$(ps | pgrep -f "dnsmasq")"
+    check="$(pgrep -f "dnsmasq")"
     if [ -n "${check}" ]
     then
         f_log "adblock lists with overall ${adb_count} domains loaded"
index de4c2fb933755ebf17e77db8a0c48b7093958cef..be656d677890c82a8cd3c3cb2896de8e21cac85e 100644 (file)
@@ -3,7 +3,7 @@
 
 config adblock 'global'
        option adb_enabled '1'
-       option adb_cfgver '2.0'
+       option adb_cfgver '2.1'
        option adb_whitelist '/etc/adblock/adblock.whitelist'
        option adb_whitelist_rset '\$1 ~/^([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\$1)}'
        option adb_forcedns '1'
@@ -115,7 +115,7 @@ config source 'whocares'
 
 config source 'winspy'
        option enabled '0'
-       option adb_src 'https://raw.githubusercontent.com/crazy-max/WindowsSpyBlocker/master/hosts/windows10_spy.txt'
+       option adb_src 'https://raw.githubusercontent.com/crazy-max/WindowsSpyBlocker/master/data/hosts/win10/spy.txt'
        option adb_src_rset '\$0 ~/^0\.0\.0\.0[ \t]+([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\$2)}'
        option adb_src_desc 'focus on windows spy & telemetry domains, infrequent updates, approx. 120 entries'
 
index e27a3fd16dc1748ed624c9ac12a9d1ad93bbc87e..7c63213e73f4ba2d09960441eae86810251a3c0e 100755 (executable)
@@ -21,10 +21,6 @@ adb_dnsprefix="adb_list"
 adb_pidfile="/var/run/adblock.pid"
 adb_log="$(which logger)"
 adb_uci="$(which uci)"
-if [ "$(${adb_uci} -q get "adblock.global.adb_restricted")" = "1" ]
-then
-    adb_uci="$(which true)"
-fi
 
 if [ -t 1 ]
 then
@@ -96,7 +92,7 @@ stop()
         /etc/init.d/dnsmasq restart
         /etc/init.d/firewall restart
     fi
-    uhttpd_pid="$(ps | pgrep -f "uhttpd -h /www/adblock")"
+    uhttpd_pid="$(pgrep -f "uhttpd -h /www/adblock")"
     if [ -n "${uhttpd_pid}" ]
     then
         kill -9 "${uhttpd_pid}"
@@ -110,6 +106,10 @@ stop()
 
 toggle()
 {
+    if [ "$(${adb_uci} -q get "adblock.global.adb_restricted")" = "1" ]
+    then
+        adb_uci="$(which true)"
+    fi
     if [ -d "${adb_dnshidedir}" ]
     then
         list_dns="$(find "${adb_dnsdir}" -maxdepth 1 -type f -name "${adb_dnsprefix}*" -print)"
@@ -130,6 +130,7 @@ toggle()
             "${adb_log}" ${log_parm} -t "adblock[${adb_pid}] info " "toggle for adblocking switched 'on'" 2>&1
         fi
     fi
+    return 0
 }
 
 cfgup()
diff --git a/utils/lrzsz/Makefile b/utils/lrzsz/Makefile
new file mode 100644 (file)
index 0000000..5074a1d
--- /dev/null
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2006-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lrzsz
+PKG_VERSION:=0.12.20
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://ohse.de/uwe/releases/
+PKG_MD5SUM:=b5ce6a74abc9b9eb2af94dffdfd372a4
+
+PKG_MAINTAINER:=Hsing-Wang Liao <kuoruan@gmail.com>
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=COPYING
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lrzsz
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=X, Y and Z-modem protocols
+  URL:=https://ohse.de/uwe/software/lrzsz.html
+endef
+
+define Package/lrzsz/description
+       Transfer files in your login sessions.
+       Very leightweight and straight forward.
+       You just need a terminal client that can do
+       either X, Y or Z-modem file transfers.
+endef
+
+define Package/lrzsz/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lrz $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lsz $(1)/usr/bin/
+       (cd $(1)/usr/bin; \
+               ln -fs lrz lrx; \
+               ln -fs lrz lrb; \
+               ln -fs lrz rz; \
+               ln -fs lrz rx; \
+               ln -fs lrz rb; \
+               ln -fs lsz lsx; \
+               ln -fs lsz lsb; \
+               ln -fs lsz sz; \
+               ln -fs lsz sx; \
+               ln -fs lsz sb; \
+       );
+endef
+
+$(eval $(call BuildPackage,lrzsz))
diff --git a/utils/lrzsz/patches/100-install_delete_fix.patch b/utils/lrzsz/patches/100-install_delete_fix.patch
new file mode 100644 (file)
index 0000000..3b19443
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -372,13 +372,13 @@
+       rm -f $(DESTDIR)/$(bindir)/`echo lsb | sed -e '$(transform)'`
+       ln $(DESTDIR)/$(bindir)/`echo lsz |sed -e '$(transform)'` \
+               $(DESTDIR)/$(bindir)/`echo lsb |sed -e '$(transform)'` 
+-      rm -f $(bindir)/`echo lsx | sed -e '$(transform)'`
++      rm -f $(DESTDIR)/$(bindir)/`echo lsx | sed -e '$(transform)'`
+       ln $(DESTDIR)/$(bindir)/`echo lsz |sed -e '$(transform)'` \
+               $(DESTDIR)/$(bindir)/`echo lsx |sed -e '$(transform)'` 
+-      rm -f $(bindir)/`echo lrb | sed -e '$(transform)'`
++      rm -f $(DESTDIR)/$(bindir)/`echo lrb | sed -e '$(transform)'`
+       ln $(DESTDIR)/$(bindir)/`echo lrz |sed -e '$(transform)'` \
+               $(DESTDIR)/$(bindir)/`echo lrb |sed -e '$(transform)'` 
+-      rm -f $(bindir)/`echo lrx | sed -e '$(transform)'`
++      rm -f $(DESTDIR)/$(bindir)/`echo lrx | sed -e '$(transform)'`
+       ln $(DESTDIR)/$(bindir)/`echo lrz |sed -e '$(transform)'` \
+               $(DESTDIR)/$(bindir)/`echo lrx |sed -e '$(transform)'` 
+ #     rm -f $(bindir)/`echo lrzszbug | sed -e '$(transform)'`