php7-pecl-libevent: drop package
authorMichael Heimpold <mhei@heimpold.de>
Thu, 9 Dec 2021 07:14:54 +0000 (08:14 +0100)
committerMichael Heimpold <mhei@heimpold.de>
Thu, 9 Dec 2021 20:57:44 +0000 (21:57 +0100)
This package is not compatible with PHP8 and seems to be not maintained
upstream anymore. Let's drop it.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php7-pecl-libevent/Makefile [deleted file]
lang/php7-pecl-libevent/patches/010-libevent2.patch [deleted file]

diff --git a/lang/php7-pecl-libevent/Makefile b/lang/php7-pecl-libevent/Makefile
deleted file mode 100644 (file)
index 99a6ca5..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PECL_NAME:=libevent
-PECL_LONGNAME:=Libevent - event notification
-
-PKG_NAME:=php7-pecl-$(PECL_NAME)
-PKG_VERSION=2019-05-30-$(PKG_SOURCE_VERSION)
-PKG_RELEASE:=2
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/expressif/pecl-event-libevent.git
-PKG_SOURCE_VERSION:=ce255e7e1e293030951fd68d5df06b2a4c077a89
-PKG_SOURCE_SUBDIR:=$(PECL_NAME)-$(PKG_SOURCE_VERSION)
-PKG_SOURCE:=$(PECL_NAME)-$(PKG_SOURCE_VERSION).tar.gz
-PKG_MIRROR_HASH:=9bb1665e020c2254bb347adc0779bea75876b8c21f2612eca723c99280a780dd
-
-PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
-
-PKG_LICENSE:=PHP-3.01
-PKG_LICENSE_FILES:=
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/pecl-php7/$(PECL_NAME)-$(PKG_SOURCE_VERSION)
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/nls.mk
-include ../php7/pecl.mk
-
-CONFIGURE_ARGS+= --with-libevent=shared,"$(STAGING_DIR)/usr"
-
-$(eval $(call PHP7PECLPackage,$(PECL_NAME),$(PECL_LONGNAME),+libevent2 +php7-mod-sockets,25))
-$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/lang/php7-pecl-libevent/patches/010-libevent2.patch b/lang/php7-pecl-libevent/patches/010-libevent2.patch
deleted file mode 100644 (file)
index 1511d29..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/libevent.c
-+++ b/libevent.c
-@@ -37,10 +37,12 @@
- # define LIBEVENT_SOCKETS_SUPPORT
- #endif
--#ifdef PHP_WIN32
-+//#ifdef PHP_WIN32
- /* XXX compiling with 2.x on Windows. Luckily the ext code works thanks to the
- compat exports from the libevent. However it might need to be adapted to the
- never version, so this ifdefs would go away. */
-+#if 1
-+/* force use of libevent2 on OpenWrt and by-pass compat event.h */
- # include <event2/event.h>
- # include <event2/event_compat.h>
- # include <event2/event_struct.h>