fping: update to 4.4 12965/head
authorRosen Penev <rosenp@gmail.com>
Tue, 28 Jul 2020 23:09:39 +0000 (16:09 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 28 Jul 2020 23:10:26 +0000 (16:10 -0700)
Remove upstreamed patch.

Whitespace Makefile cleanups.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/fping/Makefile
net/fping/patches/010-ipv6.patch [deleted file]

index 8bd0bc2e108463ac59c5fba8245626adedc37885..3c0c9782d1de09314d3f2f46d22e07e19659ac97 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fping
-PKG_VERSION:=4.3
+PKG_VERSION:=4.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://fping.org/dist/
-PKG_HASH:=92040ae842f7b8942d5cf26d8f58702a8d84c40a1fd492b415bd01b622bf372d
+PKG_HASH:=9f854b65a52dc7b1749d6743e35d0a6268179d1a724267339fc9a066b2b72d11
 
 PKG_MAINTAINER:=Nikil Mehta <nikil.mehta@gmail.com>
 PKG_LICENSE:=BSD-4-Clause
@@ -31,17 +31,16 @@ define Package/fping
   URL:=https://fping.org/
 endef
 
-
 define Package/fping/description
-       fping is a ping like program which uses the Internet Control Message Protocol
-       (ICMP) echo request to determine if a target host is responding.  fping
-       differs from ping in that you can specify any number of targets on the command
-       line, or specify a file containing the lists of targets to ping.  Instead of
-       sending to one target until it times out or replies, fping will send out a
-       ping packet and move on to the next target in a round-robin fashion.
+  fping is a ping like program which uses the Internet Control Message Protocol
+  (ICMP) echo request to determine if a target host is responding.  fping
+  differs from ping in that you can specify any number of targets on the command
+  line, or specify a file containing the lists of targets to ping.  Instead of
+  sending to one target until it times out or replies, fping will send out a
+  ping packet and move on to the next target in a round-robin fashion.
 endef
 
-CONFIGURE_ARGS+= \
+CONFIGURE_ARGS += \
        --enable-ipv4 \
        $(if $(CONFIG_IPV6),en,dis)able-ipv6
 
diff --git a/net/fping/patches/010-ipv6.patch b/net/fping/patches/010-ipv6.patch
deleted file mode 100644 (file)
index 5eba631..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From 54e97d9e393e375820e9c6ca0a56c7a4092ea5de Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Sun, 12 Jul 2020 13:55:44 +0200
-Subject: [PATCH] Fix build with --disable-ipv6
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Otherwise build breaks with:
-
-fping.c:399:14: error: ‘ident6’ undeclared (first use in this function); did you mean ‘ident4’?
-  399 |     ident4 = ident6 = getpid() & 0xFFFF;
-      |              ^~~~~~
-      |              ident4
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- src/fping.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/fping.c b/src/fping.c
-index 3522123..4304531 100644
---- a/src/fping.c
-+++ b/src/fping.c
-@@ -258,12 +258,12 @@ HOST_ENTRY* ev_last;
- char* prog;
- int ident4 = 0; /* our icmp identity field */
-+int ident6 = 0;
- int socket4 = -1;
- int using_sock_dgram4 = 0;
- #ifndef IPV6
- int hints_ai_family = AF_INET;
- #else
--int ident6 = 0;
- int socket6 = -1;
- int hints_ai_family = AF_UNSPEC;
- #endif